update the list of versions on the www.mozilla.org product

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Administration
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: masterx244, Assigned: dkl)

Tracking

Production

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8351646 [details]
shows the versions that appear on the webiste category

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

when creating a bug under the www.mozilla.org product you are required to select version


Actual results:

getting trunk /beta and some old FF versions listed
see screenshot attached


Expected results:

production or development should be available
i agree that the current list of versions configured on the product www.mozilla.org seems weird, and in need of updating.

:pmac - are you able to provide an updated list, or redirect to someone who can?
Status: UNCONFIRMED → NEW
Component: General → Administration
Ever confirmed: true
Flags: needinfo?(pmac)
Summary: Version selection shows nonfitting Versions on guided new-bug → update the list of versions on the www.mozilla.org product
We don't really have versions per se, and to my knowledge we don't use the field in BZ. I notice the versions available in the BMO product are simply "Production" and "Development/Staging", and that seems like it would work well for us too. My suggestion is to use that and make "Production" the default if possible. I'm pinging a couple other people here to see if anyone else has a better idea.
Flags: needinfo?(pmac)
Flags: needinfo?(malexis)
Flags: needinfo?(jbertsch)
Flags: needinfo?(chrismore.bugzilla)
Flags: needinfo?(booboobenny+bugzilla)
(Reporter)

Comment 3

4 years ago
would agree to the change from :pmac
(Assignee)

Comment 4

4 years ago
(In reply to masterx244 from comment #3)
> would agree to the change from :pmac

There are quite a large amount of bugs for each version that would need to be migrated before we can delete the old versions. Should we create the Production version and move all of the currently RESOLVED bugs tothat version en masse? And for unresolved, move to Development/Staging?

dkl
(In reply to David Lawrence [:dkl] from comment #4)
> There are quite a large amount of bugs for each version that would need to
> be migrated before we can delete the old versions. Should we create the
> Production version and move all of the currently RESOLVED bugs tothat
> version en masse? And for unresolved, move to Development/Staging?

I'm almost positive that we could just move all bugs to "Production". I was thinking the other version would be there mostly for bugs specific to the non-production environments. Give me some time to discuss with the team and I'll get back to you.
(In reply to David Lawrence [:dkl] from comment #4)
> There are quite a large amount of bugs for each version that would need to
> be migrated before we can delete the old versions.

my recommendation would be to deactivate versions which are no longer required, and leave any existing bugs using those versions untouched.
(Assignee)

Comment 7

4 years ago
(In reply to Byron Jones ‹:glob› (unavailable until Jan 12th) from comment #6)
> (In reply to David Lawrence [:dkl] from comment #4)
> > There are quite a large amount of bugs for each version that would need to
> > be migrated before we can delete the old versions.
> 
> my recommendation would be to deactivate versions which are no longer
> required, and leave any existing bugs using those versions untouched.

Ah yeah. That does sound better and less work ;) +1

Comment 8

4 years ago
(In reply to Byron Jones ‹:glob› (unavailable until Jan 12th) from comment #6)
> (In reply to David Lawrence [:dkl] from comment #4)
> > There are quite a large amount of bugs for each version that would need to
> > be migrated before we can delete the old versions.
> 
> my recommendation would be to deactivate versions which are no longer
> required, and leave any existing bugs using those versions untouched.

+1, but I want to make sure malexis and jbertsch have reviewed this since they own the weekly triage process.
Flags: needinfo?(chrismore.bugzilla)
Honestly, I don't use the Version field when triaging bugs and would be fine with deleting it all together.

However, since it looks like the change has already been made, I do see how Production and Development/Staging categories could be helpful.

I agree that Production should be the default if Mike agrees.

Raymond - will this be helpful to you?
Flags: needinfo?(jbertsch) → needinfo?(mozbugs.retornam)

Updated

4 years ago
Flags: needinfo?(booboobenny+bugzilla)
I'm dont have a problem with this change since I do not use the  Version field.
Flags: needinfo?(mozbugs.retornam)
(Assignee)

Comment 11

4 years ago
Done
Assignee: nobody → dkl
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(malexis)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.