Character issues with Google Groups and non-UTF8 character sets

RESOLVED DUPLICATE of bug 688144

Status

RESOLVED DUPLICATE of bug 688144
5 years ago
5 years ago

People

(Reporter: iiro.laiho, Unassigned)

Tracking

24 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36

Steps to reproduce:

1. Send something to a newsgroup or a Google Groups mailing lists with Thunderbird and a character set other than UTF-8.
2. Try to read it with the Google Groups Web UI


Actual results:

I see accented characters replaced with silly characters


Expected results:

I should see accented characters correctly. It works well with Claws-Mail.

Here is an example thread. The first message with broken characters is posted with Thunderbird and ISO character set: <https://groups.google.com/forum/#!topic/alt.test/fEALzMWj8Fc>

The problem is discussed here: <http://fixunix.com/mozilla/573913-encoding-accents-tb3-google-groups.html>
And here: <http://forums.mozillazine.org/viewtopic.php?f=39&t=2109041>

I am not sure if this is Thunderbird's or Google's fault.

Comment 1

5 years ago
could you provide the screenshot of what you try to send to google groups.

Try within thunderbird, check whether the problem with thunderbird or not.
(Reporter)

Comment 2

5 years ago
> could you provide the screenshot of what you try to send to google groups.

It was just a simple message containing the following characters:

äöå 
ÄÖÅ 

> Try within thunderbird, check whether the problem with thunderbird or not.

That does not mean anything.
(Reporter)

Comment 3

5 years ago
Google Groups shows correctly all messages except those that are sent by Thunderbird in non-UTF8 character set. Even those that are sent by other readers in non-UTF8 character set.

Also, every reader I have tried except Google Groups shows all Thunderbird's messages correctly. This is a really weird problem.

The only combination I can reproduce this is sending the message by Thunderbird in non-UTF8 character set and then reading it with Google Groups.
(Reporter)

Comment 4

5 years ago
Now I figured this out. It is beacuse Thunderbird does not use Quoted-printable encoding by default. Google Groups seems to go crazy when it encounters non-UTF8 encoding without Quoted-printable. Marking resolved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

5 years ago
I noticed that this happens with gmail, too. By the way, this seems to be duplicate of bug 688144.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 688144
You need to log in before you can comment on or make changes to this bug.