firefox 26 doesn't properly bookmark some pages

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: greta_watson, Unassigned)

Tracking

26 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131210132650

Steps to reproduce:

Go to www.amazon.com
search for a type of item, such as "earbuds"
Select one of the items , such as Panasonic earbuds

When that page comes up, in firefox (firefox 26 using Fedoral linux) select "bookmarks" and then "bookmark this page"


Actual results:

Nothing happens.


Expected results:

A window titled "Edit this Bookmark" should pop up and allow one to bookmark the page.

In Firefox 25, the window did pop up and allow one to bookmark the page.
(Reporter)

Comment 1

5 years ago
Today I downgraded Firefox, one release at a time.  I had to go all the way back to Firefox 22 before the proper action occurred.
(Reporter)

Comment 2

5 years ago
The problem is due to something in one of my bookmark folders.  I discovered this by first doing a backup of my bookmarks, creating a new user, starting the new user's Firefox, and restoring the bookmarks that I had just backed up to this new user.  So, with this new copy of the bookmarks, I was once again able to save Amazon bookmarks.

However, the restore, while getting all the bookmarks back, does not get the little icons.  For that, I had to load each bookmarked website.
Probably you places.sqlite file (that stores bookmarks & history) went corrupt.
favicons not being saved/restored is a long outstanding issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.