Closed Bug 953554 Opened 8 years ago Closed 8 years ago

Use WAI-ARIA live regions while displaying incoming messages

Categories

(Instantbird :: Conversation, defect)

0.1.2
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: pvagner)

References

()

Details

Attachments

(1 file)

*** Original post on bio 103 by Peter Vagner <pvdeejay AT gmail.com> at 2008-08-18 12:28:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
*** Original post on bio 103 as attmnt 66 by pvdeejay AT gmail.com at 2008-08-18 12:28:00 UTC ***

WAI-ARIA allows set some document elements as a live regions. Assistive technologies are then able to detect changes and act appropriatelly. E.G. in this scenario with one-line tweak we can allow screen-reading applications that understand ARIA properties to automatically speak incoming messages as they appear.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → 0.2
Version: 0.2 → 0.1.2
Comment on attachment 8351810 [details] [diff] [review]
patch setting aria-live property of elements holding each incoming message to polite.

*** Original change on bio 103 attmnt 66 at 2008-08-18 20:27:08 UTC ***

I don't know anything (yet :-)) about accessibility things that we should do in Instantbird, but let's take this for now.

The code around this will change a lot when we will design the conversation window though...

Don't hesitate to notify us if there are small code changes like this one that can improve significantly the accessibility of Instantbird.

Thank you for working on this! :-)
Attachment #8351810 - Flags: review+
*** Original post on bio 103 at 2008-08-18 20:28:19 UTC ***

Envoi          instantbird/base/content/instantbird/conversation.xml
Transmission des donnees .
Revision 280 propagee.
Assignee: florian → bugzilla
*** Original change on bio 103 at 2008-08-18 20:28:55 UTC was without comment, so any subsequent comment numbers will be shifted ***
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: 0.2 → 0.1.3
*** Original post on bio 103 by pvdeejay AT gmail.com at 2011-11-12 18:49:15 UTC ***

ooops while doing some refactoring this feature got lost. Can this be added again? Or do I need to file seperate bug?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
*** Original post on bio 103 at 2011-11-12 18:53:18 UTC ***

(In reply to comment #3)
> ooops while doing some refactoring this feature got lost. Can this be added
> again? Or do I need to file seperate bug?

Please file a separate bug.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
*** Due to an incomplete mapping of email addresses this bug did not have the proper assignee. Reassigning. ***
Assignee: bugzilla → peter.v
You need to log in before you can comment on or make changes to this bug.