Closed Bug 953630 Opened 7 years ago Closed 7 years ago

update the alias in the account manager when it's changed from the properties dialog

Categories

(Instantbird :: Account manager, defect)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: florian, Assigned: romain)

References

Details

Attachments

(1 file, 1 obsolete file)

*** Original post on bio 183 at 2009-04-24 20:57:00 UTC ***

For some reason, when the alias of an account is edited from the account properties dialog, the change is not visible in the account manager until its window is closed an reopened.
Blocks: 953623
Attached patch Patch (obsolete) — Splinter Review
*** Original post on bio 183 as attmnt 150 at 2009-07-31 13:27:00 UTC ***

I introduced a variable "item" to make things clearer, I don't know if it is the right way.

Another disadvantage is that even if the alias is not updated, or if the user press "Cancel", the alias is updated (from its old value to its old value in this last case).

But I guess it is not a big issue, because we have currently no way to know if the alias has been changed when returning from the property dialog.
Attachment #8351894 - Flags: review?(florian)
Assignee: nobody → romain
Status: NEW → ASSIGNED
Comment on attachment 8351894 [details] [diff] [review]
Patch

*** Original change on bio 183 attmnt 150 at 2009-07-31 21:37:51 UTC ***

This would not work if the alias is modified by an extension without using the account properties dialog (or without opening it from the account manager).

There should be a signal (account-updated) when the alias is changed.
I don't know if this bug is actually caused by that signal not being fired when the alias is changed (that would be something to fix in purplexpcom) or by the account manager not updating the alias when receiving that signal.
Attachment #8351894 - Flags: review?(florian) → review-
Attached patch Patch v2Splinter Review
*** Original post on bio 183 as attmnt 155 at 2009-08-01 08:50:00 UTC ***

It was far more easier than I though...
It was just a misspelled parameter (called aObject instead of aSubject).
Attachment #8351899 - Flags: review?(florian)
Comment on attachment 8351894 [details] [diff] [review]
Patch

*** Original change on bio 183 attmnt 150 at 2009-08-01 08:50:33 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8351894 - Attachment is obsolete: true
Comment on attachment 8351899 [details] [diff] [review]
Patch v2

*** Original change on bio 183 attmnt 155 at 2009-08-01 10:15:20 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8351899 - Flags: review?(florian) → review+
*** Original post on bio 183 at 2009-08-02 21:50:57 UTC ***

https://hg.instantbird.org/instantbird/rev/31267d7af41c
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: 0.2a1 → 0.2b1
You need to log in before you can comment on or make changes to this bug.