autologin disabling on crash triggers when an account has no password

RESOLVED DUPLICATE of bug 953730

Status

Chat Core
General
RESOLVED DUPLICATE of bug 953730
4 years ago
4 years ago

People

(Reporter: Romain BEZUT, Assigned: florian)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [0.2-wanted])

(Reporter)

Description

4 years ago
*** Original post on bio 228 at 2009-08-28 23:18:00 UTC ***

Steps to reproduce:
- Add an account with no password, autologin enabled
- restart instantbird, the account has no error, nor it is connected.
- make instantbird crash
- autologin disabling at startup (see Bug 953584 (bio 137)) triggers even if Instantbird crashes a few hours after autologin was performed

Issue coming from libpurple that simply does nothing when an account has no password.

Libpurple should send an error message in those cases.
(Reporter)

Updated

4 years ago
Component: Other → General
Product: Instantbird → Chat Core
(Assignee)

Comment 1

4 years ago
*** Original post on bio 228 at 2010-01-17 00:14:31 UTC ***

Shouldn't we mark the account has having an error, even before there is any connection attempt on it?
(Assignee)

Updated

4 years ago
Whiteboard: [0.2-wanted]
(Assignee)

Comment 2

4 years ago
*** Original post on bio 228 at 2010-03-04 22:55:30 UTC ***

I think this issue is fixed by my patch for bug 953730 (bio 287).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Target Milestone: 0.2 → 0.2b2
Duplicate of bug: 953730
You need to log in before you can comment on or make changes to this bug.