Closed Bug 953685 Opened 8 years ago Closed 8 years ago

The add buddy window sized incorrectly, cutting off the bottom

Categories

(Instantbird :: Other, defect)

defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: benediktp)

Details

Attachments

(3 files, 3 obsolete files)

*** Original post on bio 239 by Michael <Prescience500 AT gmail.com> at 2009-09-14 23:11:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
Attached image Bug Screenshot (obsolete) —
*** Original post on bio 239 as attmnt 241 by Prescience500 AT gmail.com at 2009-09-14 23:11:00 UTC ***

Description:
The add buddy window is cut off at the bottom in the latest nightly build of
Instantbird (0.2b1pre (20090914041854)) as shown in the attachment.

Steps to Reproduce:
1. Open Instantbird
2. Click File > Add Buddy

Expected Result:
The add buddy window is well-proportioned and shows all text and fields.

Actual Result:
The bottom of the add buddy window is cut off.
*** Original post on bio 239 by Donnie Muurdock <dgmurdockiii AT gmail.com> at 2009-09-15 02:32:06 UTC ***

im getting this to on windows 7 64 bit
*** Original post on bio 239 by Prescience500 AT gmail.com at 2009-09-15 02:59:51 UTC ***

Oh yeah, forgot to mention that I found this on Windows XP. Updating this to Windows (all).
OS: Other → Windows XP
Attached file Bug Screenshot for Windows 7 (obsolete) —
*** Original post on bio 239 as attmnt 242 by dgmurdockiii AT gmail.com at 2009-09-24 20:42:00 UTC ***

The bottom of the add buddy window is cut off
Attached image Bug Screenshot for Windows 7 (obsolete) —
*** Original post on bio 239 as attmnt 243 by dgmurdockiii AT gmail.com at 2009-09-24 20:43:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
*** Original post on bio 239 as attmnt 244 by dgmurdockiii AT gmail.com at 2009-09-24 20:44:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Comment on attachment 8351986 [details]
Bug Screenshot for Windows 7

*** Original change on bio 239 attmnt 242 by dgmurdockiii AT gmail.com at 2009-09-24 20:44:35 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8351986 - Attachment is obsolete: true
Comment on attachment 8351987 [details]
Bug Screenshot for Windows 7

*** Original change on bio 239 attmnt 243 by dgmurdockiii AT gmail.com at 2009-09-24 20:44:35 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8351987 - Attachment is obsolete: true
*** Original post on bio 239 at 2009-09-30 20:59:42 UTC ***

Could you try what the About dialog looks like? Does the same problem occur there as well?
*** Original post on bio 239 by Michael <Prescience500 AT gmail.com> at 2009-09-30 22:17:03 UTC ***

I'm not completely sure what you mean by the "About dialogue," but I checked the "about:" pages and the "About Instantbird" page. I can't find this problem there. (Windows XP)
Attached image Bug Screenshot
*** Original post on bio 239 as attmnt 257 by Prescience500 AT gmail.com at 2009-12-13 08:41:00 UTC ***

This has mysteriously improved, though there is still not enough room below the buttons for it to look right.
Comment on attachment 8351985 [details]
Bug Screenshot

*** Original change on bio 239 attmnt 241 by Prescience500 AT gmail.com at 2009-12-13 08:41:18 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8351985 - Attachment is obsolete: true
*** Original post on bio 239 at 2009-12-13 11:13:19 UTC ***

I just reproduced this on Windows XP SP3 by setting the font size to 'large' or 'extremely large' on the display properties dialog of Windows.
Though this doesn't seem to be the problem on the Windows 7 screenshot, it seems that attachment 8352000 [details] (bio-attmnt 257) is suffering from exactly this problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Original post on bio 239 as attmnt 258 at 2009-12-13 12:51:00 UTC ***

This patch removes the height and width attributes of the dialog. It now sizes to the width and height of the content. Tested on Windows XP SP3 with normal, large and extremely large font sizes. Initial problem doesn't occur anymore. Will also size to show complete account name on the drop down box now.
Attachment #8352001 - Flags: review?(florian)
Comment on attachment 8352001 [details] [diff] [review]
Removes the height and width attributes of the dialog

*** Original change on bio 239 attmnt 258 at 2009-12-13 14:41:50 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352001 - Flags: review?(florian) → review+
*** Original post on bio 239 at 2009-12-13 14:42:45 UTC ***

Fixed: https://hg.instantbird.org/instantbird/rev/55d204fbf2db
Thanks!
Assignee: nobody → benediktp
Status: NEW → RESOLVED
Closed: 8 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 0.2b2
You need to log in before you can comment on or make changes to this bug.