If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Textbox expansion on window resize

RESOLVED FIXED in 0.2

Status

Instantbird
Conversation
P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Romain BEZUT, Assigned: Romain BEZUT)

Tracking

trunk
x86
Windows XP

Details

(Whiteboard: [0.2-blocking])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
*** Original post on bio 240 at 2009-09-16 21:48:00 UTC ***

Steps to reproduce:
- Open a new conversation
- Move the splitter between the textbox and the top part (conversation browser)
- Resize the window horizontally (for example)

What happens:
The textbox expands on its own but it shouldn't!

As this bug is very common, it should be fixed before 0.2 release.
(Assignee)

Updated

4 years ago
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Updated

4 years ago
OS: All → Windows XP
Priority: -- → P2
Hardware: All → x86
(Assignee)

Comment 1

4 years ago
Created attachment 8351994 [details] [diff] [review]
Proposed patch

*** Original post on bio 240 as attmnt 250 at 2009-10-29 16:00:00 UTC ***

- Also fixing the stuff discussed in Bug 953687 (bio 241) about the default textbox size.
- Removing useless negative margins on Linux.
- There are no more incomprehensible constants (like vertical overhead).
- Adding some comments to make things clearer.
Attachment #8351994 - Flags: review?(florian)
(Assignee)

Updated

4 years ago
Assignee: nobody → romain
Status: NEW → ASSIGNED
Comment on attachment 8351994 [details] [diff] [review]
Proposed patch

*** Original change on bio 240 attmnt 250 at 2009-10-29 16:06:22 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8351994 - Attachment description: Proposed patach → Proposed patch
Attachment #8351994 - Attachment filename: patchTextboxFInal.patch → patchTextboxFinal.patch
Attachment #8351994 - Flags: review?(florian) → review+
*** Original post on bio 240 at 2009-10-29 16:15:27 UTC ***

Comment on attachment 8351994 [details] [diff] [review] (bio-attmnt 250)
Proposed patch

>diff --git a/instantbird/content/instantbird/conversation.xml b/instantbird/content/instantbird/conversation.xml

>@@ -467,34 +485,36 @@
>         if (!topMinSize || topSize - topMinSize > newDeckHeight - oldDeckHeight) {
>           // Hide a possible vertical scrollbar.
>           input.style.overflowY = "hidden";
>           deck.height = newDeckHeight;
>         }
>         else {
>           input.style.overflowY = "";
>           // Set it to the maximum possible value.
>-          deck.height = oldDeckHeight + (topSize - topMinSize);
>+          deck.height = oldDeckHeight + (topSize - topMinSize) +
>+                        bindingElt._TEXTBOX_VERTICAL_OVERHEAD;
>         }
>       ]]>
>       </body>
>      </method>

We don't need to add the constant here, because the change is based on the previous deck height.
*** Original post on bio 240 at 2009-10-29 16:20:35 UTC ***

https://hg.instantbird.org/instantbird/rev/415c74ac1a5f
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Whiteboard: [0.2-blocking]
You need to log in before you can comment on or make changes to this bug.