Bugs concerning uniform buddy tooltips

RESOLVED FIXED in 0.2b2

Status

Instantbird
Conversation
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Mic, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
*** Original post on bio 284 at 2009-12-12 12:49:00 UTC ***

There are several issues concerning the tooltips:

On the conversation window:

* Showing the tooltip on an IRC private conversation tab will bring up the most recently shown tool tip.

* Showing the tooltip for an IRC channel will show no tooltip at all. Expected bahaviour: show channel, server name and maybe even the topic.

* Maybe show tooltips on the all-tabs-menu too.

* Flickering: it's not reliably reproducable but happened several times on the following action: open several tabs, 'look at some tooltips', then drag a tab to a new window. Now the tooltip will sometimes show a flickering (wrong/no data?) before showing the correct information.
*** Original post on bio 284 at 2009-12-12 13:22:54 UTC ***

(In reply to comment #0)

> * Showing the tooltip on an IRC private conversation tab will bring up the most
> recently shown tool tip.
This is because of a JS error when opening the popup for a conversation associated with someone not in the buddy list. It's a bug we need to fix.

> * Showing the tooltip for an IRC channel will show no tooltip at all. Expected
> bahaviour: show channel, server name and maybe even the topic.
That's "expected" in the sense that the code purposefully prevents the tooltip from opening when the conversation is a chat, because there's no buddy from which we can get data for a Chat.
We will need to add some code to generate a tooltip based on information we have from the conversation an not from a buddy. This code could probably handle the case of someone not in the buddy list too.

> * Maybe show tooltips on the all-tabs-menu too.
Having popups above popups sounds scary to me. I think we should just improve a bit the message displayed in the status bar when hovering a menuitem.

> * Flickering: it's not reliably reproducable but happened several times on the
> following action: open several tabs, 'look at some tooltips', then drag a tab
> to a new window. Now the tooltip will sometimes show a flickering (wrong/no
> data?) before showing the correct information.
I can't reproduce. We will need better steps to reproduce and fix if you can find them.
Blocks: 953715
*** Original post on bio 284 at 2009-12-14 17:40:49 UTC ***

https://hg.instantbird.org/instantbird/rev/80c5b9748b86

Fixes the first 2 points. I don't think I agree with the 3rd, and I can't reproduce the 4th.

It doesn't display the topic for IRC channels, maybe I should add that.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.2b2
(Reporter)

Comment 3

5 years ago
*** Original post on bio 284 at 2009-12-14 18:34:29 UTC ***

(In reply to comment #2)
> Fixes the first 2 points. I don't think I agree with the 3rd, 
The first two were the important ones. The 3rd is not that important as bug 953716 (bio 271) also intends to show more information about the item that the users is pointing on.

> and I can't reproduce the 4th.
I'm not sure if it's not just a thing that occurs on not so fast computers under high load.
 
> It doesn't display the topic for IRC channels, maybe I should add that.
Yes, I think it would be useful.
You need to log in before you can comment on or make changes to this bug.