Closed Bug 953730 Opened 6 years ago Closed 6 years ago

Catch "no password" on protocols that require a password

Categories

(Instantbird :: Account manager, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Mic, Assigned: florian)

References

Details

(Whiteboard: [0.2-wanted])

*** Original post on bio 287 at 2009-12-14 21:06:00 UTC ***

Right now it silently reports something like 

"Error: Can not connect to account FAKE1 without a password.
Source File: http://hg.instantbird.org/instantbird/raw-file/1e468065130e/purple/libpurple/connection.c Line: 139 
Source Code: connection: _purple_connection_new"

to the error console. That's not as userfriendly as it could be ;)

Expected behaviour: output atleast an understandable error message.
Maybe prompt to enter a password (permanently or just for the session -> see bug 953702 (bio 257)).
Whiteboard: [0.2-wanted]
*** Original post on bio 287 at 2010-03-04 22:54:33 UTC ***

FIXED: https://hg.instantbird.org/instantbird/rev/f23f944fff33
Assignee: nobody → florian
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.2b2
Duplicate of this bug: 953674
You need to log in before you can comment on or make changes to this bug.