Split the instantbird skin package to remove defaults from 3rd party themes.

RESOLVED FIXED in 0.2

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: bugzilla, Assigned: florian)

Tracking

trunk
x86
Other

Details

(Whiteboard: [0.2-blocking])

(Reporter)

Description

5 years ago
*** Original post on bio 375 by patrickjdempsey <pjdkrunkt AT lycos.com> at 2010-03-10 22:35:00 UTC ***

Three of the folders in the instantbird skin package should be moved to their own package because they should not be touched by 3rd party themes.  These are:

\skin\classic\instantbird\messages
\skin\classic\instantbird\smileys
\skin\classic\instantbird\sounds

These contain data that should belong to the default theme only and not 3rd party themes.
(Reporter)

Updated

5 years ago
Summary: Split the instantbird skin package to remove defaults from themes. → Split the instantbird skin package to remove defaults from 3rd party themes.
*** Original post on bio 375 at 2010-03-13 21:16:16 UTC ***

Putting the default messages theme as part of the skin made sense when we had only one default theme which was called "default" and the default appearance of messages was logically a part of the global skin of the application.

Now that we have several themes shipped by default, I understand that it's causing an issue to have them included in the skin.

We really don't want to cause code duplication of the message themes as we want to keep our ability to fix bugs in the default themes, so I guess we really need to do something about this before the final 0.2 release.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [0.2-blocking]
*** Original post on bio 375 at 2010-03-23 22:01:18 UTC ***

https://hg.instantbird.org/instantbird/rev/1fe91d235538
Assignee: nobody → florian
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.2
Duplicate of this bug: 953837
You need to log in before you can comment on or make changes to this bug.