Error Console: filter by account/protocol

RESOLVED DUPLICATE of bug 955260

Status

Instantbird
Other
--
enhancement
RESOLVED DUPLICATE of bug 955260
4 years ago
3 years ago

People

(Reporter: Instantbot, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
*** Original post on bio 430 by John Doe <buggy AT mailinator.com> at 2010-07-03 11:14:00 UTC ***

It would be nice if I could see the console messages for one specific account or protocol only. 

The UI could be:
* a button in the account prefs: "View log for this account"
or 
* a dropdown in the error console: "Filter by account" or "Filter by protocol"
*** Original post on bio 430 at 2010-07-03 23:02:56 UTC ***

hmm, maybe adapting the Console┬▓ extension from Firefox would help?
OS: Windows XP → All
Hardware: x86 → All
*** Original post on bio 430 at 2010-07-04 00:12:51 UTC ***

The log messages from libpurple contain an indication of the "module" which produced them. I guess we can use that to filter by protocol.

Filtering by account would be more usable, but given the way libpurple works, I don't think we can currently provide a way to do it.

It would be nice to have a way to copy to the clipboard all the log messages related to an account that failed to connect properly.
*** Original post on bio 430 at 2010-12-30 10:52:27 UTC ***

See also bug 954012 (bio 575).
Duplicate of this bug: 954012
*** Original post on bio 430 at 2011-02-16 15:13:19 UTC ***

Marking this as "new", at least filtering by protocol would be useful (most users only use one of each protocol, so you'd automatically be able to filter by account too.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 0.2 → trunk
I think this is really fulfilled by bug 955260.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 955260
You need to log in before you can comment on or make changes to this bug.