User's own icon not displayed in message themes

RESOLVED FIXED in 0.3b1

Status

Instantbird
Conversation
--
minor
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Instantbot, Assigned: florian)

Tracking

Details

(Reporter)

Description

4 years ago
*** Original post on bio 448 by deOmega <jahkae AT gmail.com> at 2010-07-15 21:03:00 UTC ***

Would really like to see support for personal avatar, especially for the message styles that have room avatars within them.
*** Original post on bio 448 at 2010-09-18 09:21:18 UTC ***

What do you mean with "support for avatars" by the way?
What would you like to see where?
It would be good to know. We already have a bug about buddy icons on conversations by the way: https://bugzilla.mozilla.org/show_bug.cgi?id=953559 (bio 108)
If this is what you meant, then I'll set the bug to duplicate of bug 953559 (bio 108).
(Reporter)

Comment 2

4 years ago
*** Original post on bio 448 by deOmega <jahkae AT gmail.com> at 2010-09-18 14:20:26 UTC ***

This is regarding all the message styles that allow the visibility of icons, such as this one:
https://addons.instantbird.org/en-US/instantbird/addon/117

(Take note of the adium icons)

If the individual I am speaking with has a picture, it will show up next to their entries where you see the adium image (replacing the adium image).  However, I will not see mine (though I have one), even though the other user is able to see mine.  On my side, I would only see the adium image as my representation.   If they are using IB, they will see mine, but not theirs, hence representing the same problem I  am reporting here. (I may seem repetitive here, but  trying to eliminate the need for further clarity) 

In the past we have discussed and you have implemented other methods to help differentiating  between different contacts, as well as  conversation rows, and this is along those lines.  This I believe is also another helpful feature in that regards.  Not everyone needs them all or even any of them, but they do matter to the people who find these useful.
*** Original post on bio 448 at 2010-09-18 15:45:33 UTC ***

Sounds like a valid request, setting this bug to NEW, CC'ing Florian as well:)

I didn't know the own image was missing on such themes (I've never used one of these if I recall correctly).

Florian: is there a way to access the own buddy image (even though we're not be able to set a new one yet?)


> I may seem repetitive here, but  trying to eliminate the need for further clarity

After the description it was clear to me before even looking at the addon screenshot, so I guess the explanations were good :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

4 years ago
*** Original post on bio 448 at 2010-09-18 16:08:43 UTC ***

(In reply to comment #3)
> Florian: is there a way to access the own buddy image (even though we're not be
> able to set a new one yet?)
There's currently no scriptable way to do it (and it's even possible that libpurple doesn't know how to fetch the existing icon from the Google servers).

I think we will try to address all this when we add a way to set one's icon.
OS: Windows 7 → All
Hardware: x86 → All
Version: 0.2 → trunk
(Assignee)

Comment 5

4 years ago
*** Original post on bio 448 at 2011-01-28 14:57:40 UTC ***

This depends on or is a duplicate of bug 953777 (bio 334).
(Assignee)

Comment 6

4 years ago
*** Original post on bio 448 at 2011-05-19 13:00:53 UTC ***

(In reply to comment #5)
> This depends on or is a duplicate of bug 953777 (bio 334).

Now that bug 953777 (bio 334) is fixed, it's easy to fix this.
Assignee: nobody → florian
Depends on: 953777
Summary: User Avatar support → User's own icon not displayed in message themes
(Reporter)

Comment 7

4 years ago
*** Original post on bio 448 by deOmega <jahkae AT gmail.com> at 2011-05-19 13:02:35 UTC ***

This is REALLY great news... thank you very much.
(Assignee)

Comment 8

4 years ago
*** Original post on bio 448 at 2011-05-19 13:07:18 UTC ***

Fixed: https://hg.instantbird.org/instantbird/rev/8e1a729df269
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.3b1
You need to log in before you can comment on or make changes to this bug.