Closed Bug 953899 Opened 6 years ago Closed 11 months ago

Make window titles shorter to fit in the titlebar

Categories

(Instantbird :: Other, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: bugzilla, Unassigned)

Details

*** Original post on bio 460 by Azat Tymerkaev <tymerkaev AT gmail.com> at 2010-07-30 12:07:00 UTC ***

Bug for cleanup unneeded window titles.

Note: Windows and Linux always show application icon, and app name here's not need. Mac OS X show app name on the top.

Three steps:

1. Cleanup title of Buddies window (General).
 Rename "Buddy list" to just "Buddies" and remove word " - Instantbird".

2. Cleanup title of Accounts window.
 Rename "Accounts manager" to just "Accounts" and remove word " - Instantbird"

3. Cleanup title of Conversations window.
 Replace word " - Instantbird" to " - Conversations". It's better name for that window.
*** Original post on bio 460 at 2010-08-09 18:19:20 UTC ***

I agree with changes like
 Accounts manager -> Accounts
 Buddy list -> Contacts

Not sure about removing " - Instantbird". I think we want to do what other applications do, so as to not "stand out" on such a thing. It may not be the same on all OSes.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Original post on bio 460 at 2010-12-03 14:45:25 UTC ***

I disagree with removing " - Instantbird", it's very standard practice on Windows. (I don't remember EVER seeing an application that doesn't do it.) OK well Firefox does it now, but because it has the Firefox button.
*** Original post on bio 460 at 2010-12-03 14:52:59 UTC ***

I think on Mac removing " - Instantbird" would make sense. We need to figure out what's the common practice for each OS.
*** Original post on bio 460 at 2011-04-08 23:44:10 UTC ***

(In reply to comment #1)
> I agree with changes like
>  Accounts manager -> Accounts
>  Buddy list -> Contacts

I applied these 2 changes in https://hg.instantbird.org/instantbird/rev/dc42590bc3b3

Not sure about the " - Instantbird" suffix (we should get more data about the common behavior on each OS if we want to decide something), so I'm not closing the bug yet.
Summary: Short some window titles to match in the titlebar → Make window titles shorter to fit in the titlebar
*** Original post on bio 460 at 2012-10-12 21:50:58 UTC ***

The contact list is named just "Instantbird" now [1] by the way. Does any of the other concerns regarding the window names still persist?

[1] https://hg.instantbird.org/instantbird/rev/1704
On the behalf of Florian:
Closing bugs related to the Instantbird UI as WONTFIX, as the development of the standalone chat client Instantbird has stopped. Instantbird users are encouraged to migrate to Thunderbird. The user interface of instant messaging in Thunderbird will feel familiar, as the Thunderbird IM support started as a fork of Instantbird.
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → WONTFIX
On the behalf of Florian:
Closing bugs related to the Instantbird UI as WONTFIX, as the development of the standalone chat client Instantbird has stopped. Instantbird users are encouraged to migrate to Thunderbird. The user interface of instant messaging in Thunderbird will feel familiar, as the Thunderbird IM support started as a fork of Instantbird.
You need to log in before you can comment on or make changes to this bug.