Closed Bug 953957 Opened 7 years ago Closed 7 years ago

Unable to tell if a MUC is connected

Categories

(Instantbird :: Conversation, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: clokep, Assigned: benediktp)

References

Details

Attachments

(2 files, 4 obsolete files)

*** Original post on bio 520 at 2010-09-24 00:16:00 UTC ***

You are unable to tell if a MUC is connected via the tab since it just shows the MUC icon instead of a status icon (i.e. connected, etc.) This is annoying especially when your connection is dropping often and you're unsure you're online or not.
*** Original post on bio 520 at 2010-09-24 07:34:44 UTC ***

(Technically, this information is exposed in the API though "readonly attribute boolean left;" in the purpleIConvChat XPCOM interface.)

My first idea about it was to put the chat room name in italic or between parenthesis. However, now that you mention the icon, it seems more consistent with what we do for IM tabs :).
With the regular "status" icon, we turn the icon to gray when the contact is disconnected. Given the appearance of the current chatroom icon, it won't be possible to turn it to gray.

A few random ideas (not sure if any of them is good):
 - put a gray dot above the chatroom icon like we do for offline contacts when they are displayed in the buddy list.
 - draw a cross on top of the chatroom icon.
 - make the chatroom icon for active chats more vivid (add some colors? some more relief?) and the chatroom icon for left chats more flat. (this seemed nice at first, but I'm not sure it's really a good idea to make the default icon more eye catchy.)

Idechix, any idea about this?
Severity: normal → enhancement
*** Original post on bio 520 at 2010-09-24 11:57:36 UTC ***

(In reply to comment #1)
> A few random ideas (not sure if any of them is good):
>  - put a gray dot above the chatroom icon like we do for offline contacts when
> they are displayed in the buddy list.
+1 since it would be easy to recognize if you have seen offline buddies on the list before (might need to confirm this statement by newer users!).

>  - draw a cross on top of the chatroom icon.
A black or greyscale cross like on the close tab button could be unobstrusive enough and still carry the message?


>  - make the chatroom icon for active chats more vivid (add some colors? some
> more relief?) and the chatroom icon for left chats more flat. (this seemed nice
> at first, but I'm not sure it's really a good idea to make the default icon
> more eye catchy.)
Idea: two states of the chat icon without adding colours: the bubbles on the online chat room icon would have completely black borders and completely white inner areas while a offline chat icon would have grey or darker grey border with a greyed out inner area? Maybe this would be enough to make the two states discernable?
*** Original post on bio 520 at 2010-09-24 12:16:52 UTC ***

(In reply to comment #1)
> A few random ideas (not sure if any of them is good):
>  - put a gray dot above the chatroom icon like we do for offline contacts when
> they are displayed in the buddy list.
This is what I had originally thought of since it seems more consistent with the rest of the UI.

>  - make the chatroom icon for active chats more vivid (add some colors? some
> more relief?) and the chatroom icon for left chats more flat. (this seemed nice
> at first, but I'm not sure it's really a good idea to make the default icon
> more eye catchy.)
Perhaps adding some color for the online and then changing it to grayscale for offline could work. (Which I think is similar to what Mic said?)
*** Original post on bio 520 by Quentin Castier <idechix AT instantbird.org> at 2010-09-28 18:55:05 UTC ***

I think I will make a gray version of the 3 bubbles. Something more like if they were "disabled".
Duplicate of this bug: 954048
Attached image Gray bubbles (obsolete) —
*** Original post on bio 520 as attmnt 433 at 2010-12-18 06:16:00 UTC ***

Here's kind of what I had in mind.  Currently it doesn't seem the status gets set on the tab about whether a chat is actually available or not, it just has the property "chat" set to true and that's it.
Attached patch Patch v1 (obsolete) — Splinter Review
*** Original post on bio 520 as attmnt 473 at 2011-01-10 00:42:00 UTC ***

This patch sets the status on init of the conversation UI and observes update-chat-convleft to update if necessary. Includes CSS pieces. Icon not included.
Attachment #8352216 - Flags: review?(florian)
Assignee: nobody → benediktp
Status: NEW → ASSIGNED
Attached patch Patch - v1: icon (obsolete) — Splinter Review
*** Original post on bio 520 as attmnt 474 at 2011-01-10 00:48:00 UTC ***

I think I used an unmodified version of Patrick's icon to test. Here it is as patch.

I'm not sure if the darker grey color carries the message of an offline or parted chat well. I think it is more eye-catching than the normal chat icon and I don't like this. Still: even brighter than the normal icon doesn't sound like a good idea either. Any other ideas?
Attachment #8352217 - Flags: review?(bugzilla)
Comment on attachment 8352216 [details] [diff] [review]
Patch v1

*** Original change on bio 520 attmnt 473 at 2011-01-10 14:21:22 UTC ***

Don't bother reviewing this, it fails on (dis-)connecting accounts.
Attachment #8352216 - Flags: review?(florian)
*** Original post on bio 520 at 2011-01-14 13:38:52 UTC ***

From what I see in https://hg.instantbird.org/instantbird/file/ba17c12c2206/purple/purplexpcom/src/purpleInitConv.cpp#l209 the signal you need to be notified when the account goes offline is "update-buddy-status".

I would suggest you handle this by renaming the updateBuddyStatus method to updateConvStatus, adding only a |case "update-conv-chatleft":| line in the observe method, making the call to updateConvStatus unconditional in initConversationUI, and handling the case of MUCs in the "new" updateConvStatus.

I'm not sure using the "offline" value for parted room is a good choice, especially as for IM conversations offline means the buddy is offline, not the account.
Comment on attachment 8352217 [details] [diff] [review]
Patch - v1: icon

*** Original change on bio 520 attmnt 474 by idechix AT instantbird.org at 2011-01-14 13:58:02 UTC ***

Sorry, I think it wasn't a good idea to make grey bubbles.
It doesn't really say "hey, I'm not connected !".
The best thing to do will probably be a small grey dot that looks like the one used in buddy list.
Attachment #8352217 - Flags: review?(bugzilla) → review-
Comment on attachment 8352176 [details]
Gray bubbles

*** Original change on bio 520 attmnt 433 by idechix AT instantbird.org at 2011-01-14 14:04:27 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352176 - Attachment is obsolete: true
Attached image chat bubbles with grey dot (obsolete) —
*** Original post on bio 520 as attmnt 477 by idechix AT instantbird.org at 2011-01-14 14:07:00 UTC ***

This may be better.
*** Original post on bio 520 as attmnt 478 by idechix AT instantbird.org at 2011-01-14 14:13:00 UTC ***

An even better one ! XD
I removed the 3rd bubble.
Comment on attachment 8352220 [details]
chat bubbles with grey dot

*** Original change on bio 520 attmnt 477 by idechix AT instantbird.org at 2011-01-14 14:13:55 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352220 - Attachment is obsolete: true
*** Original post on bio 520 as attmnt 479 at 2011-01-14 15:16:00 UTC ***

I added the suggested changes. I hope I got the jar.mn file for the theme right.
Attachment #8352222 - Flags: review?(florian)
Comment on attachment 8352216 [details] [diff] [review]
Patch v1

*** Original change on bio 520 attmnt 473 at 2011-01-14 15:16:39 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352216 - Attachment is obsolete: true
Comment on attachment 8352217 [details] [diff] [review]
Patch - v1: icon

*** Original change on bio 520 attmnt 474 at 2011-01-14 15:16:39 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352217 - Attachment is obsolete: true
*** Original post on bio 520 at 2011-01-14 15:26:45 UTC ***

(In reply to comment #13)
> Created an attachment (id=478) [details]
> chat bubbles with grey dot (v2)
> 
> An even better one ! XD
> I removed the 3rd bubble.

For consistency across online/offline chats shouldn't we then remove the third bubble from the "online" chat?
*** Original post on bio 520 at 2011-01-14 16:33:26 UTC ***

(In reply to comment #15)
> (In reply to comment #13)

> > I removed the 3rd bubble.
> 
> For consistency across online/offline chats shouldn't we then remove the third
> bubble from the "online" chat?

No. We removed the 3rd bubble only because the few uncovered pixels of it were ugly on attachment 8352220 [details] (bio-attmnt 477).
Comment on attachment 8352222 [details] [diff] [review]
Changed according to review comments, added Quentin's icon

*** Original change on bio 520 attmnt 479 at 2011-01-14 16:34:57 UTC ***

Looks good, and works well (tested only on Mac).

(In reply to comment #14)

> I hope I got the jar.mn file for the theme
> right.

Seems right :).
Attachment #8352222 - Flags: review?(florian) → review+
*** Original post on bio 520 at 2011-01-14 18:07:59 UTC ***

Fixed in http://hg.instantbird.org/instantbird/rev/cdb016c2be17
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.3a1
*** Original post on bio 520 at 2011-02-07 15:31:14 UTC ***

Verified fixed on 0.3a1.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.