Closed Bug 953967 Opened 8 years ago Closed 8 years ago

update addons.instantbird.org integration in the add-on manager to follow mozilla 2 changes.

Categories

(Instantbird Servers :: addons.instantbird.org, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: benediktp, Assigned: florian)

References

Details

(Whiteboard: [0.3-blocking-final])

Attachments

(3 files)

*** Original post on bio 529 at 2010-09-29 14:38:00 UTC ***

Include addons.instantbird.org into the add-ons manager like it is done on Firefox.
*** Original post on bio 529 at 2010-10-13 21:31:33 UTC ***

Necessary steps on this bug are:

1. set up server side
2. set preference "extensions.webservice.discoverURL" to point there


Here's what Firefox gets served as "Get Add-ons" page:

https://services.addons.mozilla.org/en-US/firefox/discovery/4.0b8pre/WINNT

(expanded from https://services.addons.mozilla.org/%LOCALE%/%APP%/discovery/%VERSION%/%OS% )


CC'ing Even and flo because of the server-side bits.
*** Original post on bio 529 at 2010-10-14 08:39:13 UTC ***

Well, thanks for the tip. I expect this to need a complete AIO update to the last trunk version of remaora, which might be a real pain to do. Much more since the whole design has change and thus involve a complete re-theming from idechix.

It might take a while for us to update...

I don't know if flo wants to consider this a blocking or not but I'm OK to tell it's a problem and should be done ASAP.

It's going to be harsh because I'm overloaded at work these days and I don't believe Idechix has much more time.
*** Original post on bio 529 at 2010-10-14 09:19:01 UTC ***

I'm not really sure yet of if we need to update remora or can just do a quick hack somewhere with the URLs.

I think having a fully working add-ons manager blocks 0.3 final, and probably the betas. Not the alpha versions.
*** Original post on bio 529 at 2010-10-14 09:46:24 UTC ***

(In reply to comment #3)
> I'm not really sure yet of if we need to update remora or can just do a quick
> hack somewhere with the URLs.
> 
> I think having a fully working add-ons manager blocks 0.3 final, and probably
> the betas. Not the alpha versions.

Maybe something like the Addons-Box on the homepage would do?
Using the "featured Addons"-feed wouldn't even require touching any of the AIO code. Even though we don't have preview images then.

It's possible to get the icons using the addon-ids, which can be extracted from the feed entries to point to the icon image at

https://addons.instantbird.org/en-US/instantbird/images/addon_icon/%ADDON_ID%/

Would need to take care of non-existant icons, though.
*** Original post on bio 529 at 2010-10-14 11:23:24 UTC ***

@Florian: Well, I'm not sure about that. We might try to look at different URLs to see if we can find anything looking like the format we're looking for using the AMO website as a ref, but... I don't have high hopes for this one. I don't think the format needed by Mozilla 2 was even thought of when the version of remora we use today was released.

@Benedikt: What you suggest is somehow to rewrite the whole suggestion tab ourselves. I don't think we want to reinvent the wheel here. And it's more complicated than that. The suggestion box is thought to prevent any already installed addon to be shown in it. It might not be a good idea to use the RSS stream to find addons and to filter it to remove already installed addons from those. Looks like a lot of work for no good avail.
*** Original post on bio 529 at 2010-10-14 11:32:06 UTC ***

(In reply to comment #5)
> @Benedikt: What you suggest is somehow to rewrite the whole suggestion tab
> ourselves. I don't think we want to reinvent the wheel here. And it's more
> complicated than that. The suggestion box is thought to prevent any already
> installed addon to be shown in it.

I didn't know the add-ons discovery screen had some logics. I assumed it would be a mere browser loading a certain page. My bad.
Summary: Include AIO in AOM → update addons.instantbird.org integration in the add-on manager to follow mozilla 2 changes.
Whiteboard: [0.3-blocking]
Whiteboard: [0.3-blocking] → [0.3-blocking-final]
*** Original post on bio 529 at 2011-06-06 17:07:59 UTC ***

I spent most of the afternoon investigating this.

Instantbird uses the add-ons website in 4 different ways:
1. searching for add-ons to install, and installing them.
2. Showing the 'discovery' pane.
3. Updating existing add-ons.
4. The 'More' links we have in several places of the UI.

1. Doesn't work out-of-the-box because the format of the XML file has slightly changed. I have a patch to make our existing remora installation use the new format when the API version is 1.5 or more.

For 2., I think we should just put up a static HTML page somewhere, probably extracting the first box of https://services.addons.mozilla.org/en-US/firefox/discovery/pane/version/OS
Hmm... we may even want to put in inside the application in chrome:// if that's possible.

3. I haven't tested this yet, but I believe if there are problems, they should be limited and fixable.

4. Shouldn't be affected by the account manager change.


I don't know what it's used for exactly, but we need to add the extensions.getAddons.cache.enabled preference to shut up a warning.


Given all of this, I don't think attempting to do a full update of the website would be a good use of our time. Especially given that it's been completely rewritten in Python, and we would do our Instantbird adaptation and theming from scratch.
Attached patch Patch for 1.Splinter Review
*** Original post on bio 529 as attmnt 699 at 2011-06-06 17:09:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352442 - Flags: review?(bugzilla)
*** Original post on bio 529 at 2011-06-06 17:23:02 UTC ***

(In reply to comment #7)
> I don't know what it's used for exactly, but we need to add the
> extensions.getAddons.cache.enabled preference to shut up a warning.
This is bug 953998 (bio 562), I did some research on that and there's a couple of links in that bug. (Marking this as depends on bug 953998 (bio 562).)
Depends on: 953998
Comment on attachment 8352442 [details] [diff] [review]
Patch for 1.

*** Original change on bio 529 attmnt 699 at 2011-06-06 17:34:44 UTC ***

I don't like this kind of PHP but it looks right to me, and there's no reason to do otherwise on this piece of crap where everything already looks like this, so : r+.
Attachment #8352442 - Flags: review?(bugzilla) → review+
*** Original post on bio 529 at 2011-06-06 19:23:11 UTC ***

(In reply to comment #10)
> (From update of attachment 8352442 [details] [diff] [review] (bio-attmnt 699) [details])
> I don't like this kind of PHP but [...] there's no reason
> to do otherwise on this [...] where everything already looks like this

I dislike it too, but I tried to follow the "coding style" :-).
*** Original post on bio 529 at 2011-06-07 09:54:33 UTC ***

Comment on attachment 8352442 [details] [diff] [review] (bio-attmnt 699)
Patch for 1.

http://hg.instantbird.org/websites/remora/rev/0dc0cd4ef585
Attached patch Patch for 2.Splinter Review
*** Original post on bio 529 as attmnt 700 at 2011-06-07 13:36:00 UTC ***

This adds a XUL page to be used as the discovery pane.
+ it adds extensions.getAddons.cache.enabled (set to false per IRC discussion) to silence the related warning.
Attachment #8352443 - Flags: review?(clokep)
Assignee: nobody → florian
Status: NEW → ASSIGNED
*** Original post on bio 529 as attmnt 701 at 2011-06-07 13:39:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Comment on attachment 8352443 [details] [diff] [review]
Patch for 2.

*** Original change on bio 529 attmnt 700 at 2011-06-07 13:44:09 UTC ***

This looks good! Unfortunately it breaks the string freeze, but I think it's definitely a better situation than the alternatives.
Attachment #8352443 - Flags: review?(clokep) → review+
*** Original post on bio 529 at 2011-06-07 22:53:39 UTC ***

https://hg.instantbird.org/instantbird/rev/71cbaabb817d - make links work when clicked

https://hg.instantbird.org/instantbird/rev/2e00b5c94702 attachment 8352443 [details] [diff] [review] (bio-attmnt 700) (discovery pane + fix for bug 953998 (bio 562))
*** Original post on bio 529 at 2011-06-09 10:11:33 UTC ***

(In reply to comment #7)

> Instantbird uses the add-ons website in 4 different ways:
> 1. searching for add-ons to install, and installing them.
> 2. Showing the 'discovery' pane.
> 3. Updating existing add-ons.
> 4. The 'More' links we have in several places of the UI.
[...]
> 
> 3. I haven't tested this yet, but I believe if there are problems, they should
> be limited and fixable.
> 
> 4. Shouldn't be affected by the account manager change.

I've just done some testing, and I can confirm that the points 3 and 4 from comment 7 work. Resolving as FIXED, yay!
Severity: enhancement → normal
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.3b1
Component: Other → addons.instantbird.org
Product: Instantbird → Instantbird Servers
Target Milestone: 0.3b1 → ---
Version: trunk → unspecified
You need to log in before you can comment on or make changes to this bug.