Improve Facebook override protocol: disable "Join chat" option, remove advanced options

RESOLVED FIXED in 0.3b1

Status

Instantbird
Other
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: clokep, Assigned: florian)

Tracking

Details

(Whiteboard: [0.3-wanted-final])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
*** Original post on bio 532 at 2010-10-01 17:21:00 UTC ***

Some protocol overrides (i.e. Facebook for XMPP) are unable to join chat rooms, but since XMPP supports chats, Facebook "does" also. In the join chat window Facebook shows up as an option. I think flo had a patch for this at one point but I'm not positive.
*** Original post on bio 532 at 2010-10-02 14:32:50 UTC ***

We already have this as bug 953903 (bio 464) which covers other cases like offline messages as well (Facebook doesn't support them while XMPP should (reason for this behaviour: they're using a wrapper for their internal chat API and not a proper XMPP server)).

Setting to RESOLVED DUPLICATE.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 953903
(Assignee)

Comment 2

4 years ago
*** Original post on bio 532 at 2011-01-28 16:17:19 UTC ***

This seems fixable. We probably also want to hide most advanced options (that make no sense) in the Facebook override.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

4 years ago
Whiteboard: [0.3-wanted]
(Assignee)

Updated

4 years ago
Whiteboard: [0.3-wanted] → [0.3-wanted-final]
(Assignee)

Comment 3

4 years ago
Created attachment 8352407 [details] [diff] [review]
Patch v1

*** Original post on bio 532 as attmnt 664 at 2011-05-30 10:26:00 UTC ***

- Disable 'Join Chat' on Facebook.
- Remove all the advanced options on Facebook.

- Should we also remove all the advanced options on GTalk?

By the way, the proxy options are hidden for protocol overrides (hiding them was intended JS proto, but they should be visible for override protocols if the base is a libpurple protocol). Not sure if this is/should be handled in a separate bug.
(Assignee)

Comment 4

4 years ago
*** Original post on bio 532 at 2011-05-30 10:34:32 UTC ***

(In reply to comment #3)

> By the way, the proxy options are hidden for protocol overrides (hiding them
> was intended JS proto, but they should be visible for override protocols if the
> base is a libpurple protocol). Not sure if this is/should be handled in a
> separate bug.

This is an error in the patch from bug 954084 (bio 649), trivially fixed by adding:
  get usePurpleProxy() this.base.usePurpleProxy
at the end of ForwardProtocolPrototype. I'll push it and post a link to the follow-up changeset in bug 954084 (bio 649).
Summary: Disable "Join chat" for protocol overrides that don't support it (Facebook) → Improve Facebook override protocol: disable "Join chat" option, remove advanced options
(Assignee)

Comment 5

4 years ago
Created attachment 8352408 [details] [diff] [review]
Patch v2

*** Original post on bio 532 as attmnt 665 at 2011-05-30 15:36:00 UTC ***

Handle the options that used to be special cased in the account wizard.
(Assignee)

Comment 6

4 years ago
Comment on attachment 8352407 [details] [diff] [review]
Patch v1

*** Original change on bio 532 attmnt 664 at 2011-05-30 15:36:19 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352407 - Attachment is obsolete: true
(Assignee)

Comment 7

4 years ago
*** Original post on bio 532 at 2011-05-30 17:59:15 UTC ***

Fixed: https://hg.instantbird.org/instantbird/rev/1023849b0d65
Assignee: nobody → florian
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.3b1
You need to log in before you can comment on or make changes to this bug.