Enhance Facebook XMPP-chat with missing features

RESOLVED WONTFIX

Status

Chat Core
General
--
enhancement
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: Mic, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
*** Original post on bio 538 at 2010-10-07 12:19:00 UTC ***

There was a discussion in #instantbird if Facebook chat should be reimplemented in Javascript, using their web api instead of the xmpp gateway which doesn't support anything but chatting.
Afaik the web chat supports setting visibility for certain groups, changing groups, moving buddies between groups and much more.
(Reporter)

Comment 1

4 years ago
*** Original post on bio 538 at 2010-10-07 12:20:41 UTC ***

(In reply to comment #0)

> 14:17:27 - clokep: The only scary part about that is what happens when they change their API? ;)

We could still fall back to XMPP until the protocol plugin is fixed.
*** Original post on bio 538 at 2010-10-07 12:45:07 UTC ***

Some documentation of the protocol: http://coderrr.wordpress.com/2008/05/06/facebook-chat-api/
And a Git repo to go along with that post: http://github.com/coderrr/facebook_chat (not this is written in Ruby)

Features/Limitations of the XMPP Gateway: http://developers.facebook.com/docs/chat

Also supposedly Adium doesn't use the Gateway and has their own protocol? From what I've read it seems that way, but I might have misunderstood.

Comment 3

4 years ago
*** Original post on bio 538 at 2010-10-07 12:54:18 UTC ***

Well, as a matter of fact, Facebook now uses XMPP as default protocol. The Facebook Chat API is now a laer above XMPP. That makes me believe this bug should be closed.

Writing a XMPP extension in JS would be more appropriate, I believe.

Flo? Should we close this one?
(Reporter)

Comment 4

4 years ago
*** Original post on bio 538 at 2010-10-07 13:55:36 UTC ***

Their XMPP support is no real XMPP. You can't move buddies between groups, can't create groups, can't .. you name it.

The suggestion was based on this:
http://log.bezut.info/instantbird/101003/#m88
*** Original post on bio 538 at 2010-10-07 14:59:10 UTC ***

(In reply to comment #3)
> Well, as a matter of fact, Facebook now uses XMPP as default protocol. The
> Facebook Chat API is now a laer above XMPP. That makes me believe this bug
> should be closed.
Facebook uses XMPP as a gateway to their own protocol layer AFAIK, as Mic mentioned the gateway is missing a lot of functionality that is available via their raw protocol implemented on their webpage. I haven't tried viewing the http data on Facebook yet though to see if its actually implementing XMPP or not. The link I posted to the Facebook Developer page has more information about this.

> Writing a XMPP extension in JS would be more appropriate, I believe.
Do you mean write an XMPP protocol in JS or write something to be able to handle XMPP extensions?  The former is on my plate for after IRC, but it probably won't be for a while.

Comment 6

4 years ago
*** Original post on bio 538 by Eion Robb <eion AT robbmob.com> at 2011-07-20 23:24:26 UTC ***

If you implement OAuth XMPP login (https://bugzilla.mozilla.org/show_bug.cgi?id=954371 (bio 938)) you can use the standard Facebook API to fill in the gaps of the missing functionality.
Duplicate of this bug: 954371
(Reporter)

Comment 8

4 years ago
*** Original post on bio 538 at 2012-10-01 10:01:45 UTC ***

(In reply to comment #6)
> If you implement OAuth XMPP login
> (https://bugzilla.mozilla.org/show_bug.cgi?id=954371 (bio 938)) you can use the standard
> Facebook API to fill in the gaps of the missing functionality.

This sounds like a reasonable way. Managing tags/groups/list or whatever they call that these days might be a candidate for that.

I'll reopen bug 954371 (bio 938) and depend this bug on it.
Depends on: 954371
Summary: Reimplement Facebook chat → Enhance Facebook XMPP-chat with missing features
Duplicate of this bug: 954371
The Facebook Chat API isn't actually usable since it doesn't let you send messages with it.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.