'pref not found' - warning when opening themes pane on preferences

RESOLVED FIXED in 0.3b1

Status

Instantbird
Preferences
--
minor
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Mic, Assigned: florian)

Tracking

Details

(Reporter)

Description

5 years ago
*** Original post on bio 562 at 2010-10-26 14:03:00 UTC ***

The following warning appears on the console when opening the preferences window and going to the themes pane.

 Warning: WARN addons.repository: cacheEnabled: Couldn't get pref: extensions.getAddons.cache.enabled

Effect: no perceivable effects.
(Reporter)

Comment 1

5 years ago
*** Original post on bio 562 at 2010-11-13 23:15:14 UTC ***

Can't reproduce with nightlies from 2010-11-07 on Windows. Can someone else check if that occurs for him? Will check on Linux again soon.
*** Original post on bio 562 at 2010-12-03 14:36:16 UTC ***

(In reply to comment #1)
> Can't reproduce with nightlies from 2010-11-07 on Windows. Can someone else
> check if that occurs for him? Will check on Linux again soon.

I'm still getting this on 20101201041630 (Windows).
(Reporter)

Comment 3

5 years ago
*** Original post on bio 562 at 2010-12-03 16:18:30 UTC ***

No wonder I couldn't reproduce it anymore. It seems that I created the preference and set it to false :(
*** Original post on bio 562 at 2011-05-11 12:27:04 UTC ***

I think we just need to add this as a default pref and set it to true.  For more info see [1].

We need to add the following to [2]:
pref("extensions.getAddons.cache.enabled", true);

Unfortunately the server won't do anything with this information, but it'll stop the warning. :)

[1] http://blog.mozilla.com/addons/how-to-opt-out-of-add-on-metadata-updates/
[2] http://lxr.instantbird.org/instantbird/source/instantbird/app/profile/all-instantbird.js
Blocks: 953967
(Assignee)

Comment 5

5 years ago
*** Original post on bio 562 at 2011-06-07 22:55:16 UTC ***

This was fixed in https://hg.instantbird.org/instantbird/rev/2e00b5c94702 as part of bug 953967 (bio 529).
After some discussion on IRC, we decided "false" was the right value because we aren't going to use that data on the server and the added server load would be a pure waste.
Assignee: nobody → florian
Status: NEW → RESOLVED
Last Resolved: 5 years ago
OS: Linux → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 0.3b1
You need to log in before you can comment on or make changes to this bug.