Richtext formatting for outgoing messages

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
6 months ago

People

(Reporter: clokep, Unassigned, Mentored)

Tracking

Details

(Whiteboard: [wanted])

Attachments

(2 attachments, 4 obsolete attachments)

(Reporter)

Description

5 years ago
*** Original post on bio 634 at 2010-12-18 21:24:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
(Reporter)

Comment 1

5 years ago
Posted patch WIP v0.1 (obsolete) — Splinter Review
*** Original post on bio 634 as attmnt 435 at 2010-12-18 21:24:00 UTC ***

I didn't see a bug for this, but it's possible I missed it. Note this is currently on the roadmap for 0.3.

We need to be able to format outgoing text.  I'm attaching a WIP that replaces the input box with an editor element, but nothing really "works" yet.  It might make more sense to make a richtextbox binding and hide all the "magic" in there) or use a premade one such as CKEditor ([L]GPL/MPL) [1], TinyMCE (LGPL) [2], or possible the editor from BlueGriffon (MPL/GPL/LGPL) (I'm not sure how much that has been abstracted -- I can't find it in his source) [3].  There's also the comm-central composer we could look at [4].

Some other applicable information:
http://www.mozilla.org/editor/
https://developer.mozilla.org/en/XUL/editor
https://developer.mozilla.org/en/using_the_editor_from_xul

[1] http://ckeditor.com/
[2] http://tinymce.moxiecode.com/
[3] http://sources.disruptive-innovations.com/bluegriffon/trunk/
[4] http://mxr.mozilla.org/comm-central/source/editor/ui/
(Reporter)

Comment 2

5 years ago
*** Original post on bio 634 at 2010-12-18 22:32:21 UTC ***

From brainstorming with Mic on IRC we seem to need the follow:
Font color, font size, font face, bold, italic, underline, maybe strike-through, an insert smiley drop down, an insert link button.

These might also need to be configurable depending on the protocol Ii.e. IRC supports some colors only, while AIM supports basic HTML).
(Reporter)

Comment 3

5 years ago
Posted patch WIP v0.5 (obsolete) — Splinter Review
*** Original post on bio 634 as attmnt 437 at 2010-12-19 17:28:00 UTC ***

Everything "works" again, I just need to get it to send things as HTML as opposed to text.
(Reporter)

Comment 4

5 years ago
Comment on attachment 8352178 [details] [diff] [review]
WIP v0.1

*** Original change on bio 634 attmnt 435 at 2010-12-19 17:28:03 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352178 - Attachment is obsolete: true
(Reporter)

Updated

5 years ago
Assignee: nobody → clokep
Status: NEW → ASSIGNED
(Reporter)

Comment 5

5 years ago
Posted patch WIP v0.5.1 (obsolete) — Splinter Review
*** Original post on bio 634 as attmnt 438 at 2010-12-19 18:01:00 UTC ***

Apparently my tree wasn't clean so that had a lot of junk in that last patch. Here's a cleaner version of it.

To get the HTML out it seems I need to use https://developer.mozilla.org/en/NsIEditor or http://mxr.mozilla.org/mozilla-central/source/editor/idl/nsIHTMLEditor.idl but I'm not sure if libpurple expects an escaped message or raw HTML or what. Done with this for the next few days.
(Reporter)

Comment 6

5 years ago
Comment on attachment 8352180 [details] [diff] [review]
WIP v0.5

*** Original change on bio 634 attmnt 437 at 2010-12-19 18:01:29 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352180 - Attachment is obsolete: true
(Reporter)

Comment 7

5 years ago
Posted patch WIP v0.6 (obsolete) — Splinter Review
*** Original post on bio 634 as attmnt 465 at 2011-01-04 03:35:00 UTC ***

Saving my progress in a patch.  At this point everything works except resizing.
(Reporter)

Comment 8

5 years ago
Comment on attachment 8352181 [details] [diff] [review]
WIP v0.5.1

*** Original change on bio 634 attmnt 438 at 2011-01-04 03:35:59 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352181 - Attachment is obsolete: true
(Reporter)

Comment 9

5 years ago
Posted patch WIP v0.6.1Splinter Review
*** Original post on bio 634 as attmnt 466 at 2011-01-04 04:40:00 UTC ***

v0.6 was missing the diff for richtextbox.xml and instantbird.css.
(Reporter)

Comment 10

5 years ago
Comment on attachment 8352208 [details] [diff] [review]
WIP v0.6

*** Original change on bio 634 attmnt 465 at 2011-01-04 04:40:22 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352208 - Attachment is obsolete: true
*** Original post on bio 634 at 2011-01-04 10:53:50 UTC ***

(In reply to comment #5)
> Created an attachment (id=466) [details]
> WIP v0.6.1
> 
> v0.6 was missing the diff for richtextbox.xml and instantbird.css.

I don't think you wanted to include your jsProtoHelper.jsm changes here, but that doesn't matter if it's just a backup :).

Updated

5 years ago
Summary: Richtext Formatting for Outgoing Messages → Richtext formatting for outgoing messages
Whiteboard: [0.3-nice-to-have]
(Reporter)

Comment 12

5 years ago
*** Original post on bio 634 at 2011-04-14 12:32:44 UTC ***

I'm not actively working on this anymore. I might come back to it, but someone else can feel free to pick it up. I'm also not sure separating out the richtextbox into a separate binding is worth the hassle.
(Reporter)

Updated

5 years ago
Version: 0.3a1 → trunk
Whiteboard: [0.3-nice-to-have] → [0.3-wanted-beta]
*** Original post on bio 634 at 2011-06-01 09:19:16 UTC ***

I tried to work on this yesterday. Unfortunately, there are way to many changes required for this for it to be still doable for 0.3 at this point. :-(
Whiteboard: [0.3-wanted-beta] → [wanted]
*** Original post on bio 634 as attmnt 679 at 2011-06-01 10:32:00 UTC ***

If we are not fixing this for 0.3, I think we should remove the dead code related to that feature that's been there since before the 0.1 release, as it may have a performance impact.

Per discussion on IRC, this can't land until the textbox regression from bug 954056 (bio 620) is fixed.
*** Original post on bio 634 at 2011-06-16 18:12:25 UTC ***

Comment on attachment 8352422 [details] [diff] [review] (bio-attmnt 679)
Dead code removal

Pushed as https://hg.instantbird.org/instantbird/rev/f83df26edc14
(Reporter)

Updated

5 years ago
Blocks: 954626

Updated

5 years ago
Duplicate of this bug: 954544
(Reporter)

Comment 18

5 years ago
I'm not actively working on this.
Assignee: clokep → nobody
(Reporter)

Updated

5 years ago
Mentor: clokep

Comment 19

4 years ago
Might be worth looking at this https://github.com/neilj/squire from Fastmail too.
On the behalf of Florian:
Closing bugs related to the Instantbird UI as WONTFIX, as the development of the standalone chat client Instantbird has stopped. Instantbird users are encouraged to migrate to Thunderbird. The user interface of instant messaging in Thunderbird will feel familiar, as the Thunderbird IM support started as a fork of Instantbird.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.