Closed Bug 954087 Opened 7 years ago Closed 7 years ago

Plaintext formatting breaks when string does not end in letter

Categories

(Instantbird :: Conversation, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 949066

People

(Reporter: clokep, Unassigned)

References

Details

*** Original post on bio 652 at 2011-01-10 16:28:00 UTC ***

The plaintext formatting added in bug 953981 (bio 543) breaks when the last part of the substring to be formatted is not a letter.

I.e. *bold* works but not *bold2* or *bold.* or anything like that. This is most likely to be seen with the |code| tags, where you might have a function call or something at the end such as:
|Services.obs.addObserver(this, "account-[dis]connected", false);|

I did a little bit of testing but I can't figure out what is causing this.

Documentation for the text converter is at: http://www.bucksch.org/1/projects/mozilla/16507/
Depends on: 953981
This is a duplicate of a Mozilla bug: bug 949066.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 949066
You need to log in before you can comment on or make changes to this bug.