Missing accesskey for "Sign-on at startup" checkbox

RESOLVED FIXED in 0.3a1

Status

defect
--
minor
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Mic, Assigned: Mic)

Tracking

trunk
0.3a1
x86
Windows XP

Details

Attachments

(1 attachment)

*** Original post on bio 659 at 2011-01-19 19:33:00 UTC ***

There's no accesskey for the "Sign-on at startup"-checkbox on accounts in the list of the account manager.

Is this maybe a technical issue because each account has such a box  and an accesskey would have to be unique on a window (not exactly 'window' but it is good enough here)?
Posted patch Add accesskeySplinter Review
*** Original post on bio 659 as attmnt 492 at 2011-01-19 21:58:00 UTC ***

Adding an accesskey to the checkbox didn't show any problems (on Windows), the accesskey is usable and only changes the checkbox of the selected account (accesskey for hidden elements are disabled?).

"u" might be a rather unusual choice here but it was the first vowel on a word that has something to do with the action and that wasn't in use ("a" in "at" seemed strange to use).
Attachment #8352235 - Flags: review?(florian)
Assignee: nobody → benediktp
Status: NEW → ASSIGNED
Comment on attachment 8352235 [details] [diff] [review]
Add accesskey

*** Original change on bio 659 attmnt 492 at 2011-01-24 19:47:37 UTC ***

Looks good.
Attachment #8352235 - Flags: review?(florian) → review+
*** Original post on bio 659 at 2011-01-24 19:48:25 UTC ***

I pushed this as https://hg.instantbird.org/instantbird/rev/3c80407cffcb with the accesskey changed from 'u' to 'S', per the discussion we just had on IRC.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.3a1
You need to log in before you can comment on or make changes to this bug.