Sign off transition not starting/finishing

RESOLVED FIXED in 1.0

Status

Instantbird
Contacts window
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: clokep, Assigned: florian)

Tracking

Details

(Whiteboard: [0.3-wanted-final], URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
*** Original post on bio 675 at 2011-02-03 15:08:00 UTC ***

Sometimes when buddies sign off they leave a white space on the buddy list and never fully collapse (you can close and reopen the group to have it collapse).

Other times the transition never starts and the buddy is left gray/italic (i.e. offline), but I don't view offline buddies! (These buddies will NOT disappear after collapsing the buddy list.)

This error might be related:
>Error: observer is undefined
>Source File: resource://gre/components/imContacts.js
>Line: 446

I don't have STR right now, it doesn't seem to happen w/ the same people necessarily, etc.
(Reporter)

Comment 1

5 years ago
Created attachment 8352254 [details]
Screenshot of both issues happening (check the arrows)

*** Original post on bio 675 as attmnt 513 at 2011-02-03 15:08:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
(Assignee)

Comment 2

5 years ago
*** Original post on bio 675 at 2011-02-03 15:56:51 UTC ***

(In reply to comment #0)

> Other times the transition never starts and the buddy is left gray/italic (i.e.
> offline)
The transition should start when the text is gray and italic, that's state=fading in the CSS.
Offline is status=offline and only implies the grey dot above the protocol icon.

Are you sure the buddy display names were gray/italic? (that's not visible on your screenshot).
(Reporter)

Comment 3

5 years ago
*** Original post on bio 675 at 2011-02-03 16:07:50 UTC ***

(In reply to comment #2)
> (In reply to comment #0)
> Are you sure the buddy display names were gray/italic? (that's not visible on
> your screenshot).

Just checked again and you're correct. The names are black and non-italic.
(Assignee)

Comment 4

5 years ago
*** Original post on bio 675 at 2011-02-03 19:28:19 UTC ***

(In reply to comment #3)

> Just checked again and you're correct. The names are black and non-italic.

Ok, so we probably can't blame CSS transitions for that part of the issues you are seeing. The JS error you pasted is more likely to be the actual cause.
*** Original post on bio 675 at 2011-02-07 15:42:41 UTC ***

I've seen blank spaces on the buddy list.
Closing and opening the group again filled the same spaces with now-offline buddies (pale icon with grey dot; font was black iirc and definitely not italic). "Show offline buddies" is disabled.

I can't tell if there was an error on the console, I'll check next time I see it.
(Reporter)

Comment 6

5 years ago
*** Original post on bio 675 at 2011-02-09 02:11:33 UTC ***

(In reply to comment #5)
> I've seen blank spaces on the buddy list.
> Closing and opening the group again filled the same spaces with now-offline
> buddies (pale icon with grey dot; font was black iirc and definitely not
> italic). "Show offline buddies" is disabled.
I've seen this as well now actually (where it doesn't clear once the group is closed/reopened).

Mic, you're on Windows XP, right?
*** Original post on bio 675 at 2011-03-02 22:17:24 UTC ***

(In reply to comment #6)
> Mic, you're on Windows XP, right?

Yes, I am (sorry for the late reply, it seems I missed the question before).
(Assignee)

Comment 8

5 years ago
*** Original post on bio 675 at 2011-03-09 10:00:42 UTC ***

This seems common enough that it's probably blocking :(. Too bad we still don't have steps to reproduce.
Whiteboard: [0.3-blocking]
(Assignee)

Comment 9

5 years ago
*** Original post on bio 675 at 2011-04-01 09:58:41 UTC ***

I've just seen this again :(.

However, some of the details described here can no longer be reproduced because of some changes I've landed recently that mitigate the effects of this bug:

- The JS error mentioned in comment 0 should be fixed by https://hg.instantbird.org/instantbird/rev/527b0060da8e

- Closing a group will now finish pending removal transitions (https://hg.instantbird.org/instantbird/rev/92ddd2bc69a5) and actually remove the contacts immediately, so "Closing and opening the group again filled the same spaces with now-offline buddies" (comment 5) doesn't apply anymore.
(Reporter)

Comment 10

5 years ago
*** Original post on bio 675 at 2011-05-11 13:49:22 UTC ***

Since this is happening much less now I'm removing the blocking status of this bug. If this is happening often for some one, please add the blocking status back.

It seems this is the same as mozbio 608589 which is fixed by mozbio 613888. But it still occurs in some places possible (mozbio 652543)

https://bugzilla.mozilla.org/show_bug.cgi?id=608589
https://bugzilla.mozilla.org/show_bug.cgi?id=613888
https://bugzilla.mozilla.org/show_bug.cgi?id=652543
OS: Windows 7 → All
Hardware: x86 → All
Whiteboard: [0.3-blocking]
*** Original post on bio 675 at 2011-05-21 12:08:39 UTC ***

(In reply to comment #10)
> Since this is happening much less now I'm removing the blocking status of this
> bug. If this is happening often for some one, please add the blocking status
> back.
> 
> It seems this is the same as mozbio 608589 which is fixed by mozbio 613888. But
> it still occurs in some places possible (mozbio 652543)
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=608589
> https://bugzilla.mozilla.org/show_bug.cgi?id=613888
> https://bugzilla.mozilla.org/show_bug.cgi?id=652543

I've just seen this again.

And I noticed that Enter, double clicks, F2 (editing name) all worked as for visible contacts by the way.
(Assignee)

Comment 12

5 years ago
*** Original post on bio 675 at 2011-05-21 12:52:38 UTC ***

I saw this once this week too. I think I have an idea of the cause. To save CPU resources, the Mozilla "refresh driver" can be slowed down to the point of firing only once per second for background windows. Each time I've seen this issue, I discovered the result when focusing the buddy list where a contact signed on/off while the list wasn't visible. It may be possible that the transitionend event is never dispatched if the transition should be already finished when the refresh driver (firing several hundred ms late) would be about to start it. At this point it's just a supposition of course.
(Assignee)

Comment 13

5 years ago
Created attachment 8352425 [details] [diff] [review]
Change refresh rate

*** Original post on bio 675 as attmnt 682 at 2011-06-01 22:40:00 UTC ***

If my supposition in comment 12 is right, this patch will work around the issue by using a refresh rate that is hight enough to ensure one refresh in the middle of each or our transitions.
My limited testing of this this evening didn't give any satisfying result with this change though :-/. I really wish I had a reliable way to reproduce the issue...
(Assignee)

Updated

5 years ago
Whiteboard: [0.3-wanted-final]
(Assignee)

Comment 14

5 years ago
*** Original post on bio 675 at 2011-06-23 09:09:40 UTC ***

I added timers yesterday in https://hg.instantbird.org/instantbird/rev/ca16aba596fb to make this issue disappear.
Assignee: nobody → florian
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Assignee)

Updated

5 years ago
Duplicate of this bug: 954161
You need to log in before you can comment on or make changes to this bug.