Closed Bug 954117 Opened 6 years ago Closed 6 years ago

Reply to and retweet actions on twitter

Categories

(Chat Core :: Twitter, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: florian, Assigned: florian)

References

Details

(Whiteboard: [wanted])

Attachments

(2 files, 1 obsolete file)

*** Original post on bio 682 at 2011-02-04 13:34:00 UTC ***

We should expose "retweet" and "reply" actions on twitter messages. As I see it, the user would click on a button on a floating toolbar appearing when hovering the tweet, or maybe in the context menu of the message.
Then the UI should somehow remember that the message currently typed is a retweet or a reply so that the correct meta data can be sent with the tweet.

I don't know yet how:
 - how we will expose the possible actions related to a message,
 - how we can give the additional meta-data to the protocol plugin. Maybe we will need to add some optional parameters to the sendMsg method of purpleIConversation.
 - how we can show in the UI that the tweet will be sent as a reply or a retweet, and how we can let the user cancel that without sending/closing the conversation.
Blocks: 954113
Whiteboard: [0.3-wanted]
Whiteboard: [0.3-wanted] → [0.3-wanted-beta]
*** Original post on bio 682 at 2011-05-29 23:10:34 UTC ***

Too late to start working on this for 0.3 now.
Whiteboard: [0.3-wanted-beta] → [wanted]
Duplicate of this bug: 954250
Attached image Twitter feed example
*** Original post on bio 682 as attmnt 675 by jahkae AT gmail.com at 2011-05-31 18:21:00 UTC ***

Just wanted to add an attachment showing  how the reply options could appear. Please note that these are visible from hovering.
Component: General → Twitter
Attached patch Patch v1 (WIP) (obsolete) — Splinter Review
*** Original post on bio 682 as attmnt 806 at 2011-09-06 22:33:00 UTC ***

This patch exposes the "Retweet" action from the context menu.
Attached patch Patch v2Splinter Review
*** Original post on bio 682 as attmnt 807 at 2011-09-07 10:54:00 UTC ***

RT and Reply actions. I think it's ready! :)
Attachment #8352549 - Flags: review?
Comment on attachment 8352548 [details] [diff] [review]
Patch v1 (WIP)

*** Original change on bio 682 attmnt 806 at 2011-09-07 10:54:18 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352548 - Attachment is obsolete: true
Assignee: nobody → florian
Status: NEW → ASSIGNED
Duplicate of this bug: 954457
Comment on attachment 8352549 [details] [diff] [review]
Patch v2

*** Original change on bio 682 attmnt 807 at 2011-09-09 10:37:49 UTC ***

Reviewed over IRC.
Attachment #8352549 - Flags: review? → review+
*** Original post on bio 682 at 2011-09-09 10:39:43 UTC ***

Pushed as https://hg.instantbird.org/instantbird/rev/6ae5289ed94d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.1
You need to log in before you can comment on or make changes to this bug.