arrowscrollbox buttons remain off-screen after resizing window

REOPENED
Unassigned

Status

()

REOPENED
18 years ago
10 years ago

People

(Reporter: ra_hardy, Unassigned)

Tracking

Trunk
mozilla1.2alpha
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080110

The URL specified demonstrates an arrowscrollbox.  After scrolling, and then
resizing the window, the scroll arrows disappear even though the buttons are
off-screen, leaving no way of scrolling to the buttons.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.xulplanet.com/tutorials/xultu/examples/ex_5_4_1.xul
2. Make sure the browser window is small enough to get scroll arrows
3. Scroll down as far as you can go
4. Drag the lower window border down to resize it, until it's clear of the
lowest button


Actual Results:  The scroll arrows disappear, leaving the top-most buttons
off-screen and no way to get to them (another than refreshing)

Expected Results:  The bottom button should align itself to the bottom of the
window border as you resize

Comment 1

18 years ago
Works fine for me on Windows 95 with build 2001081504

Comment 2

18 years ago
Yep. I see what you mean. (I'm guessing that MozillaUser may have missed 
something in the steps to reproduce). Not sure where you would encounter 
this in a UI, but your 'Expected results' is what I would expect to happen
too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
--> jag
Assignee: trudelle → jaggernaut

Comment 4

18 years ago
May God have mercy on us all. The 212 bug spam-o-rama is Now!
QA Contact: aegis → jrgm

Comment 5

17 years ago
-> 1.0
Target Milestone: --- → mozilla1.0

Comment 6

17 years ago
-> 1.2
Target Milestone: mozilla1.0 → mozilla1.2
(Reporter)

Comment 7

17 years ago
Actually, the arrows don't appear now on the url given.  Is this because xul has
changed and the tutorial needs updating?   (moz 0.9.6)
WFM on WinXP trunk build 2002072408.

Way to long since there has been any activity here.. I'm just closing it. Reopen
if necessary.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

17 years ago
The bug's still present in Moz 1.0
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 10

15 years ago
Still present. Using Firefox 0.8
(Reporter)

Comment 11

12 years ago
Still present. Using Firefox 1.5.0.6.

Updated

10 years ago
Assignee: jag → nobody
You need to log in before you can comment on or make changes to this bug.