Closed Bug 954194 Opened 7 years ago Closed 7 years ago

Clicking a growl notification should activate the application

Categories

(Instantbird :: Conversation, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: bugzilla, Assigned: florian)

Details

Attachments

(1 file)

*** Original post on bio 760 by Lurch <lurch AT flyingninjamonkey.net> at 2011-04-20 09:55:00 UTC ***

Hey guys,
Just a thought. The Growl pop-ups (ie for new incoming message) aren't click-able.
If when they come up, you could click on them and it took you straight to that conversation window (or that related tab) would make life easier.

Cheers,
Jase
*** Original post on bio 760 at 2011-04-20 12:18:31 UTC ***

Uhhh...so I've never used the notifications that pop up, but looking at the code it SHOULD be clickable [1].

Is the alert not clickable or does nothing happen after it's clicked? (I've never used Growl, what I mean by is: Is the alert styled to be clickable, if Growl even uses a different style to show clickable vs. non-clickable notifications?)

Is there an error in the error console? (Tools > Error Console)

[1] http://lxr.instantbird.org/instantbird/source/instantbird/modules/ibNotifications.jsm#88 shows an observer that should focus the conversation.
Severity: enhancement → normal
*** Original post on bio 760 by Lurch <lurch AT flyingninjamonkey.net> at 2011-04-20 12:22:20 UTC ***

Yeah, you click it, but nothing happens.
Nothing related to Growl in the error log
Making adjustments in Growl doesnt make any difference either.

Cheers,
Jase
*** Original post on bio 760 at 2011-04-20 12:43:39 UTC ***

(In reply to comment #2)
> Nothing related to Growl in the error log
Any errors would probably talk about the nsIAlertsService or something similar, not Growl specifically. Could be the alert is working ok too and something else is breaking, so...the error could be unrelated. :)

I'll try to reproduce on Windows this afternoon! Thanks! (If not...someone with a Mac will have to try to reproduce.)
*** Original post on bio 760 at 2011-04-21 13:46:14 UTC ***

I just checked again, it works for me.

When a growl notification is clicked, the conversation tab associated with the conversation is selected, and the conversation window is focused.

There's just one thing that's a bit unusual and rather annoying though: when we call window.focus on mac, the window is moved forward but stays behind the currently active window if the active window was from another application. I believe this is a Mozilla bug.

If the current application was in a fullscreen window when you clicked the notification, it can explain why it seemed to do nothing.
*** Original post on bio 760 by Lurch <lurch AT flyingninjamonkey.net> at 2011-04-21 13:48:21 UTC ***

Gotchya, can it be worked around?
Attached patch PatchSplinter Review
*** Original post on bio 760 as attmnt 594 at 2011-04-21 14:45:00 UTC ***

(In reply to comment #5)
> Gotchya, can it be worked around?

I thought the answer here was 'no' and did my best to find a convincing way to show it, but I accidentally found a good workaround :).
Assignee: nobody → florian
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 8352336 [details] [diff] [review]
Patch

*** Original change on bio 760 attmnt 594 at 2011-04-21 14:58:11 UTC ***

From the dicussion on IRC and checking the code, haven't tested it myself though.
Attachment #8352336 - Flags: review+
*** Original post on bio 760 at 2011-04-21 15:36:59 UTC ***

Pushed attachment 8352336 [details] [diff] [review] (bio-attmnt 594) as https://hg.instantbird.org/instantbird/rev/86841bb8b4c9.

Resolving as FIXED.

Jase, you should be able to verify that it works for you when the next nightly is out tomorrow. Nightlies are downloadable from http://ftp.instantbird.com/instantbird/nightly/latest-trunk/.

Thanks for the report / motivating me to fix this long standing issue!
Summary: Growl Notifications → Clicking a growl notification should activate the application
Target Milestone: --- → 0.3b1
*** Original post on bio 760 by Lurch <lurch AT flyingninjamonkey.net> at 2011-04-21 23:47:21 UTC ***

Hey man - no prob. :)
*** Original post on bio 760 by Lurch <lurch AT flyingninjamonkey.net> at 2011-04-22 08:52:53 UTC ***

Tested brilliantly - thanks for that :)
*** Original post on bio 760 at 2011-04-22 09:07:32 UTC ***

Uh, I forgot to actually mark the bug as resolved even though I said I was doing it in comment 8.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
*** Original post on bio 760 at 2011-04-22 09:08:12 UTC ***

Verified fixed, per comment 10. :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.