Make conversation tabs look like Firefox 4 tabs

RESOLVED FIXED in 0.3b1

Status

Instantbird
Conversation
--
enhancement
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: florian, Assigned: florian)

Tracking

(Blocks: 1 bug)

Details

(Whiteboard: [0.3-wanted])

Attachments

(2 attachments, 3 obsolete attachments)

(Assignee)

Description

4 years ago
*** Original post on bio 768 at 2011-04-30 01:01:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
(Assignee)

Comment 1

4 years ago
Created attachment 8352345 [details] [diff] [review]
WIP (works only on Mac)

*** Original post on bio 768 as attmnt 602 at 2011-04-30 01:01:00 UTC ***

The attached work-in-progress works only on Mac.
Animations when adding/removing tabs are not supported.
(Assignee)

Comment 2

4 years ago
Created attachment 8352347 [details] [diff] [review]
WIP (Mac and Linux)

*** Original post on bio 768 as attmnt 604 at 2011-05-02 15:59:00 UTC ***

Also works on Linux.
(Assignee)

Comment 3

4 years ago
Comment on attachment 8352345 [details] [diff] [review]
WIP (works only on Mac)

*** Original change on bio 768 attmnt 602 at 2011-05-02 15:59:05 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352345 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Assignee: nobody → florian
Status: NEW → ASSIGNED
(Assignee)

Comment 4

4 years ago
Created attachment 8352348 [details] [diff] [review]
Works on the 3 supported OSes

*** Original post on bio 768 as attmnt 605 at 2011-05-02 20:00:00 UTC ***

I would like to test Firefox 4 on my Windows VM to compare the behavior and ensure nothing is broken before pushing this.

Also, the aero version is completely untested, it's just a best effort port of the Firefox code, and it looks so much like black magic that I wouldn't expect it to 'just work' at the first attempt.
(Assignee)

Comment 5

4 years ago
Comment on attachment 8352347 [details] [diff] [review]
WIP (Mac and Linux)

*** Original change on bio 768 attmnt 604 at 2011-05-02 20:00:39 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352347 - Attachment is obsolete: true
(Assignee)

Comment 6

4 years ago
Created attachment 8352349 [details] [diff] [review]
Patch v4

*** Original post on bio 768 as attmnt 606 at 2011-05-04 14:21:00 UTC ***

Fixed some details after testing on Windows XP.

Aero version included but disabled as it's not ready yet. Someone should feel free to work on it in another bug :).
(Assignee)

Comment 7

4 years ago
Comment on attachment 8352348 [details] [diff] [review]
Works on the 3 supported OSes

*** Original change on bio 768 attmnt 605 at 2011-05-04 14:21:46 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352348 - Attachment is obsolete: true
(Assignee)

Comment 8

4 years ago
Created attachment 8352350 [details] [diff] [review]
Interdiff (attachment 605 [details] and 606)

*** Original post on bio 768 as attmnt 607 at 2011-05-04 14:22:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
(Assignee)

Comment 9

4 years ago
*** Original post on bio 768 at 2011-05-04 14:53:37 UTC ***

https://hg.instantbird.org/instantbird/rev/3e0f99aee2cd
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
OS: Other → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 0.3b1
(Assignee)

Updated

4 years ago
Whiteboard: [0.3-wanted]
Blocks: 954205

Updated

4 years ago
Duplicate of this bug: 953972
You need to log in before you can comment on or make changes to this bug.