Add access keys menu bar items

RESOLVED FIXED in 1.3

Status

--
enhancement
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: FeuerFliege, Assigned: FeuerFliege)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
*** Original post on bio 833 at 2011-06-08 06:59:00 UTC ***

The menu bar and its items should have access keys.

Missing: 

File → Add Buddy...
File → Join Chat... (bug 953859 (bio 418))
File → Set Status to...
Tools → Add-ons
Help → About Instantbird (string already in locales)
*** Original post on bio 833 at 2011-09-09 13:46:21 UTC ***

(In reply to comment #0)
> The menu bar and its items should have access keys.
> 
> Missing: 
> 
> File → Add Buddy...
> File → Join Chat... (bug 953859 (bio 418))
> File → Set Status to...
> Tools → Add-ons
> Help → About Instantbird (string already in locales)
Bug 954362 (bio 929) fixed some of these (Join Chat, Add Buddy, Add-ons), but "Set Status" and "About Instantbird" are still not keyboard accessible. Thanks for reporting this!
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
(Assignee)

Comment 2

5 years ago
Created attachment 8353749 [details] [diff] [review]
Patch 1 - Add accesskeys missed by fix for bug 929

*** Original post on bio 833 as attmnt 1990 at 2012-10-19 10:48:00 UTC ***

Accesskeys for Set Status, statuses, Minimize to Tray and the tray icon context menu (not sure if that is usefull, but "Exit" was already accessable an I just added the rest)
Attachment #8353749 - Flags: review?(florian)
(Assignee)

Updated

5 years ago
Assignee: nobody → bug
Status: NEW → ASSIGNED
Comment on attachment 8353749 [details] [diff] [review]
Patch 1 - Add accesskeys missed by fix for bug 929

*** Original change on bio 833 attmnt 1990 at 2012-10-27 03:01:17 UTC ***

Would you want to add the status accesskeys at http://lxr.instantbird.org/instantbird/source/instantbird/content/blist.xul#126 too? r- because I assume the answer is yes, but if there's a reason why they wouldn't be appropriate there, please re-request review :-).
Thanks for polishing these accesskeys!
Attachment #8353749 - Flags: review?(florian) → review-
(Assignee)

Comment 4

5 years ago
*** Original post on bio 833 at 2012-10-27 11:29:45 UTC ***

Well, it is quite hard (not to say nearly impossible) to open that selection with keyboard only, so I didn't saw the need for access keys. But I could add them anyway, if you want.
(Assignee)

Comment 5

5 years ago
Created attachment 8353776 [details] [diff] [review]
Patch 2 - Add accesskeys missed by fix for bug 929

*** Original post on bio 833 as attmnt 2016 at 2012-10-27 14:31:00 UTC ***

Previous patch + added accesskeys to the menu of the status icon button
Attachment #8353776 - Flags: review?(florian)
(Assignee)

Comment 6

5 years ago
Comment on attachment 8353749 [details] [diff] [review]
Patch 1 - Add accesskeys missed by fix for bug 929

*** Original change on bio 833 attmnt 1990 at 2012-10-27 14:31:15 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8353749 - Attachment is obsolete: true
*** Original post on bio 833 at 2012-10-27 17:08:33 UTC ***

(In reply to comment #4)
> Well, it is quite hard (not to say nearly impossible) to open that selection
> with keyboard only,

aleth has just fixed this in bug 955087 (bio 1658).
Comment on attachment 8353776 [details] [diff] [review]
Patch 2 - Add accesskeys missed by fix for bug 929

*** Original change on bio 833 attmnt 2016 at 2012-11-02 23:42:01 UTC ***

Thanks.

Note: applying this patch was painful because it has bitrotted with http://hg.instantbird.org/instantbird/rev/d43481fa4668.
Attachment #8353776 - Flags: review?(florian) → review+
*** Original post on bio 833 at 2012-11-03 04:24:45 UTC ***

Committed as http://hg.instantbird.org/instantbird/rev/0d2e723c6ada
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3
You need to log in before you can comment on or make changes to this bug.