make IRC protocol link "localizable"

RESOLVED FIXED

Status

Instantbird Servers
www.instantbird.com
--
enhancement
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Instantbot, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
*** Original post on bio 856 by Michal Stanke <michal.stanke AT mikk.cz> at 2011-06-27 13:30:00 UTC ***

On the main page (index) are some IM icons with link above the IB download button.
Especially for IRC link (currently referring to en.wikipedia.org) would be the feature of localization profitable.
*** Original post on bio 856 at 2011-06-27 13:43:36 UTC ***

Is IRC the only link that needs to be localized?
(Reporter)

Comment 2

4 years ago
*** Original post on bio 856 by Michal Stanke <michal.stanke AT mikk.cz> at 2011-06-27 14:03:35 UTC ***

I hope so. All other site are recognizing the language, if there is any.

For example in Czech Republic are some comunities around the protocols (concretely jabbim.cz is the biggest XMPP server), so why to not enable this feature for all of these links?
*** Original post on bio 856 at 2011-06-27 14:14:32 UTC ***

(In reply to comment #1)
> Is IRC the only link that needs to be localized?

Just link to RFC 1459 instead. ;)

(In reply to comment #2)
> I hope so. All other site are recognizing the language, if there is any.
> For example in Czech Republic are some comunities around the protocols
> (concretely jabbim.cz is the biggest XMPP server), so why to not enable this
> feature for all of these links?

I don't think we should link to communities in the case of XMPP, since the current link is to the standards organization (that offers a variety of information about XMPP).
*** Original post on bio 856 at 2011-06-27 14:17:41 UTC ***

(In reply to comment #2)

> why to not enable this feature for all of these links?

I would really prefer if we could avoid HTTP urls inside locale files.

For the IRC wikipedia URL, I can just build a static list of the per-locale URL and select the right one (bonus: already complete translations don't need to change anything :) to have this fixed).
*** Original post on bio 856 at 2011-06-27 16:19:07 UTC ***

https://hg.instantbird.org/websites/www.instantbird.com/rev/45beaf8a09f8
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Summary: make protocol links "localizable" → make IRC protocol link "localizable"
You need to log in before you can comment on or make changes to this bug.