Incorrect text on "Get Add-ons" page

RESOLVED FIXED in 1.1

Status

Instantbird
Other
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aleth, Assigned: florian)

Tracking

Details

(Whiteboard: [1.1-blocking])

(Reporter)

Description

4 years ago
*** Original post on bio 872 at 2011-06-29 17:00:00 UTC ***

On the Get Add-Ons page, it currently says "What are Add-ons? ... When you're connected to the internet, this pane will feature some of the best and most popular add-ons for you to try out". 

I don't think that statement is true. I am certainly connected to the internet  ;)

It would be better to put a link to the add-on site there instead, *and* to have a message pointing people at the search bar. Knowing about this built-in method of installing add-ons would save newbies from downloading xpi files manually.
(Reporter)

Comment 1

4 years ago
*** Original post on bio 872 at 2011-06-29 17:03:56 UTC ***

Or indeed put a custom webpage there like in Firefox.
*** Original post on bio 872 at 2011-06-29 17:39:40 UTC ***

I think it was something like "works the first time when opening the addon manager, broken when opening it the next time".
Can you confirm these steps to reproduce?
(Assignee)

Comment 3

4 years ago
*** Original post on bio 872 at 2011-06-29 17:43:28 UTC ***

(In reply to comment #2)

> Can you confirm these steps to reproduce?

Yes :-(. Can I add [0.3-blocking-final] to the whiteboard? ;-)
(Reporter)

Comment 4

4 years ago
*** Original post on bio 872 at 2011-06-29 17:51:48 UTC ***

You mean, "the first time opening the add-on manager after loading IB"? I have tried that and it still does not show up.
(Reporter)

Comment 5

4 years ago
*** Original post on bio 872 at 2011-07-08 13:43:30 UTC ***

Correction: I have now also observed the "works the first time only" behaviour (IB 1.0)
*** Original post on bio 872 at 2011-07-09 07:27:08 UTC ***

(In reply to comment #5)
> Correction: I have now also observed the "works the first time only" behaviour
> (IB 1.0)

I can't reproduce on version 1.1a1pre (20110709041719). Maybe the problem was automagically fixed by upgrading to moz5?
Hardware: x86 → All
(Reporter)

Comment 7

4 years ago
*** Original post on bio 872 at 2011-07-09 13:04:45 UTC ***

I just checked with the latest nighty and unfortunately this is not the case. Play around with opening and closing the add-on manager etc and the problem invariably occurs.
(Assignee)

Comment 8

4 years ago
*** Original post on bio 872 at 2011-09-29 10:59:40 UTC ***

If this can still be reproduced, this may block 1.1 :-(
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [1.1-blocking]
(Assignee)

Comment 9

4 years ago
*** Original post on bio 872 at 2011-10-02 21:52:18 UTC ***

So, this bug can't be reproduced on a debug build (which wasted a lot of my time :-(), but can consistently be reproduced on non-debug builds.

The issue is that the add-on manager assumes that a load finishing with the status NS_ERROR_PARSED_DATA_CACHED failed, and fallbacks to the error page in that case.

When the page displayed in the Get Add-ons tab is local, it gets cached and we have that result code when reloading it.

I patched the extensions.js Mozilla file:
https://hg.instantbird.org/instantbird/rev/f5d2827c16b1

I think we want to attempt to upstream that patch (otherwise this bug will still be an issue for linux distribution packages).
Assignee: nobody → florian
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.1
(Assignee)

Comment 10

4 years ago
*** Original post on bio 872 at 2011-11-19 23:12:33 UTC ***

(In reply to comment #9)

> I think we want to attempt to upstream that patch (otherwise this bug will
> still be an issue for linux distribution packages).

I've just filed this bug on it: https://bugzilla.mozilla.org/show_bug.cgi?id=703929
(Assignee)

Comment 11

4 years ago
*** Original post on bio 872 at 2011-12-16 14:25:38 UTC ***

(In reply to comment #10)
> (In reply to comment #9)
> 
> > I think we want to attempt to upstream that patch (otherwise this bug will
> > still be an issue for linux distribution packages).
> 
> I've just filed this bug on it:
> https://bugzilla.mozilla.org/show_bug.cgi?id=703929

FIXED for Mozilla 11 :)
You need to log in before you can comment on or make changes to this bug.