bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Unable to register to multiple Twitter account : 'username incorrect'

RESOLVED FIXED in 1.1

Status

Instantbird
Account wizard
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Instantbot, Assigned: florian)

Tracking

Details

(Whiteboard: [1.1-blocking])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
*** Original post on bio 875 by Patrick Installe <PatrickInstalle AT P-Installe.be> at 2011-06-30 07:10:00 UTC ***

When I try to register to a second twitter account the twitter authorization is connected to the first account. Ok, minor problem, I disconnect. Then I give the second twitter account username and password. The registration fail with error "username incorrect" :-( . Note that for twitter the application is correctly registred in the second account.
(Assignee)

Updated

5 years ago
Whiteboard: [1.1-blocking]
*** Original post on bio 875 at 2011-09-16 02:01:02 UTC ***

This is confirmed as WFM by Florian over IRC [1]. This might be related to bug 954361 (bio 928).

[1] http://log.bezut.info/instantbird/110915/#m490
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 2

5 years ago
*** Original post on bio 875 at 2011-09-16 08:53:29 UTC ***

Unfortunately, while double checking with a nightly (I was wondering if it could be one of these annoying issues that work fine in debug builds and fail in optimized builds), I found the steps to reproduce.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Assignee)

Comment 3

5 years ago
*** Original post on bio 875 at 2011-09-16 08:56:00 UTC ***

Steps to reproduce:
 - configure a first twitter account and connect it.
 - configure a second twitter account. When attempting to connect it, the OAuth dialog opens without login/password fields, just the "authorize" button. Clicking it authorizes instantbird for the first twitter account.

Note: restarting Instantbird before connecting the second account doesn't cause this problem, so I suspect the issue is caused by a session cookie.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

5 years ago
Created attachment 8352570 [details] [diff] [review]
Disable cookies

*** Original post on bio 875 as attmnt 827 at 2011-09-16 09:31:00 UTC ***

Disabling all cookies fixes the bug for me.
Could this cause an issue somewhere else?
Comment on attachment 8352570 [details] [diff] [review]
Disable cookies

*** Original change on bio 875 attmnt 827 at 2011-09-16 10:22:22 UTC ***

Looks good, I'd prefer just rejected Twitter.com ones, but this is certainly easier. If there's an issue we'll have to relook at this.
Attachment #8352570 - Flags: review+
*** Original post on bio 875 at 2011-09-16 11:52:01 UTC ***

Checked in as: http://hg.instantbird.org/instantbird/rev/1f9ddea970ac

Thanks for reporting this! :)
Assignee: nobody → florian
Status: NEW → RESOLVED
Last Resolved: 5 years ago5 years ago
OS: Linux → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.1
(Assignee)

Comment 7

5 years ago
*** Original post on bio 875 at 2011-09-16 14:02:50 UTC ***

(In reply to comment #5)
> (From update of attachment 8352570 [details] [diff] [review] (bio-attmnt 827) [details])
> Looks good, I'd prefer just rejected Twitter.com ones, but this is certainly
> easier. If there's an issue we'll have to relook at this.

For future reference, if we ever want to go that route, there's some example code here:
http://mxr.mozilla.org/mozilla-central/source/browser/components/preferences/aboutPermissions.js#212 (the "get cookies()" getter and "clearCookies" method).
(Assignee)

Comment 8

5 years ago
*** Original post on bio 875 at 2011-10-03 21:28:35 UTC ***

I've just pushed https://hg.instantbird.org/instantbird/rev/9b7b79505301 which will make the OAuth dialog pop-up again for accounts that don't have a valid OAuth token (either because of this bug or because the user has revoked the token from the twitter web UI). This should help people fix accounts that have been affected by this bug; if there are still any :-).
You need to log in before you can comment on or make changes to this bug.