CPU usage high on CSS Style viewer demo. Anim gif's stopped.

RESOLVED WORKSFORME

Status

()

Core
Layout: Images
--
major
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Martin Poirier, Assigned: Stuart Parmenter)

Tracking

({perf, regression})

Trunk
Future
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Win98SE, mozilla build 2001081504

Reproducible : Always

Steps :
1. Open browser
2. Choose debug | viewer demos | #1 CSS Styles
3. Look below the words Bulleted List, there are some animated gears.
4. Scroll to the very bottom of the page
5. Notice the gears aren't animated anymore and CPU usage is close to 100%
6. Also notice that if you put your cursor over the Back, FWD, Reload or Stop
button, the cursor is flickering.

Actual result : High CPU usage causing visual defects

Expected Result : Mozilla should smoothly handle this page

Updated

17 years ago
Keywords: perf

Comment 1

17 years ago
seeing this on win98 2001081703

-> style system for initial triage
Assignee: asa → pierre
Status: UNCONFIRMED → NEW
Component: Browser-General → Style System
Ever confirmed: true
QA Contact: doronr → ian

Comment 2

17 years ago
I confirm the problem on the Mac.  It is a recent regression, probably related to 
the ImageLib landing (bug 78690).

Curiously enough on the Mac when the application is in the background, the gears 
turn again.  When the app is front, the gears stop and it looks like we spend the 
entire time drawing again and again.

Raised severity and reassigned to ImageLib.
Assignee: pierre → pavlov
Severity: normal → major
Component: Style System → ImageLib
Keywords: regression
OS: Windows 98 → All
QA Contact: ian → tpreston
Hardware: PC → All

Comment 3

17 years ago
looks OK on my win2k box, cpu usage is barely mesurable, no where near 100%,
much less 10%. Will try on Mac

Updated

17 years ago
Blocks: 119597
(Assignee)

Updated

16 years ago
Target Milestone: --- → Future

Comment 4

16 years ago
Saw this bug while looking for CSS issues on the Mac platform. Just FYI, the
steps below work just fine for me under OS X 10.1.3 and Moz .9.9.
(Assignee)

Comment 5

16 years ago
wfm
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Component: ImageLib → Image: Layout
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.