Closed Bug 954487 Opened 7 years ago Closed 7 years ago

Closing first tab using the [x]-icon doesn't remove unread status of second tab

Categories

(Instantbird :: Conversation, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: benediktp, Assigned: florian)

Details

(Whiteboard: [1.1-wanted])

*** Original post on bio 1053 at 2011-09-27 14:31:00 UTC ***

When closing the first tab, the second tab will be selected. The unread status of the second tab is usally removed then. This works fine when closing the first tab using the context menu, the keyboard shortcut or a middle click. It does not work though when using the close icon of the first tab.

I guess it is a focus problem.
*** Original post on bio 1053 at 2011-09-27 20:05:57 UTC ***

Worksforme on Mac, do you think it's Windows-only? Or could it be caused by an add-on you have?
*** Original post on bio 1053 at 2011-09-28 09:38:29 UTC ***

I've now tried again with a new profile on the most recent nightly (20110928041602) and I'm still seeing the same problem.

Patrick, could you also try to reproduce this on Windows? Thanks in advance!
*** Original post on bio 1053 at 2011-09-28 10:22:39 UTC ***

(In reply to comment #2)
> I've now tried again with a new profile on the most recent nightly
> (20110928041602) and I'm still seeing the same problem.
> 
> Patrick, could you also try to reproduce this on Windows? Thanks in advance!

I can confirm that it stays as unread when using the close button.
*** Original post on bio 1053 at 2011-09-29 11:19:30 UTC ***

I've seen this on Linux too.
OS: Windows 7 → All
*** Original post on bio 1053 at 2011-09-29 11:58:12 UTC ***

Is this a regression? May be something we want to attempt to debug before releasing 1.1 :-/.
Whiteboard: [1.1-wanted]
*** Original post on bio 1053 at 2011-10-02 21:47:33 UTC ***

The code attempting to keep the focus on the tab bar when the user is navigating through the tabs with the keyboard (especially the arrow keys) is preventing the newly selected conversation from getting focused.

The difference of behavior between Mac and Windows/Linux is probably because the click event is on mouseup in a case and on mousedown in the other case. I guess that means on Linux/Windows the tab gets focused by the click before it's closed; I wanted to prevent that default action, but I haven't succeeded.

Instead I pushed https://hg.instantbird.org/instantbird/rev/9d67e566488e which is more or less a work-around: focus on the tab bar is ignored if the focused element is a tab that's being closed.

I'm not satisfied with that code, as I think there are probably still other issues with edge-cases, but for 1.1 that patch will do :-).
Assignee: nobody → florian
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.1
You need to log in before you can comment on or make changes to this bug.