Collapsing contact info in buddy list with mouse will hide the contact

RESOLVED FIXED in 1.1

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: FeuerFliege, Assigned: florian)

Tracking

trunk
x86
Windows 7

Details

(Whiteboard: [1.1-blocking])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
*** Original post on bio 1066 at 2011-10-11 13:03:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
(Reporter)

Comment 1

5 years ago
Created attachment 8352616 [details]
click circled button, contact will be hidden

*** Original post on bio 1066 as attmnt 873 at 2011-10-11 13:03:00 UTC ***

Open detailed contact information (right cursor) and collaspe the info with the mouse (not keyboard!) again.

Expected: only info disappears
Actual result: contact gets hidden

Instantbird version:  1.1a1pre (20111011092429)

Flo said via IRC hat he couldn't reproduce, can anybody reproduce?

Comment 2

5 years ago
Created attachment 8352617 [details]
Invisible Contacts

*** Original post on bio 1066 as attmnt 874 by mattdentremont AT gmail.com at 2011-10-11 14:21:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
*** Original post on bio 1066 at 2011-10-11 14:28:12 UTC ***

Need to investigate this before shipping :(
Whiteboard: [1.1-blocking]
*** Original post on bio 1066 at 2011-10-11 14:36:27 UTC ***

I'm seeing this (no pun intended) with 20111011092429 on Windows 7.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

5 years ago
*** Original post on bio 1066 at 2011-10-12 08:24:42 UTC ***

You cannot expand the contact info by using the mouse, maybe that is connected.

When you try to expand the list, the line with the expand arrow will disappear.
(Reporter)

Comment 6

5 years ago
*** Original post on bio 1066 at 2011-10-12 08:40:36 UTC ***

It is a regession:

last good: version 1.1a1pre (20110921041646)
first bad: version 1.1a1pre (20110922041631)
(Reporter)

Comment 7

5 years ago
*** Original post on bio 1066 at 2011-10-12 08:41:09 UTC ***

It is a regression:

last good: version 1.1a1pre (20110921041646)
first bad: version 1.1a1pre (20110922041631)
*** Original post on bio 1066 at 2011-10-12 09:05:22 UTC ***

In that range it's likely from https://hg.instantbird.org/instantbird/rev/74d6a3f1d658
(Reporter)

Comment 9

5 years ago
*** Original post on bio 1066 at 2011-10-12 09:31:05 UTC ***

This lines are causing the regression:
http://hg.instantbird.org/instantbird/rev/74d6a3f1d658#l1.7

It seems the buddylistbox does not get the focus, when the expand/collapse button is pressed by mouse.

This bug can be fixed by rechangeing the "#buddylistbox:focus > contact[selected]" to "contact[selected]" but of cause the intended appearence will be changed.


You can see the difference by adding the following lines to chrome/userChrome.css:


contact[selected] {
    -moz-binding: url("chrome://instantbird/content/contact.xml#contact-big")!important;
    -moz-box-orient: vertical!important;
    -moz-box-align: stretch !important;
	}
*** Original post on bio 1066 at 2011-10-12 15:18:49 UTC ***

Fixed by https://hg.instantbird.org/instantbird/rev/549c2079e180

The problem was that the buttons were stealing the focus from the buddylistbox when clicked and that changed the binding used for the selected contact.
Assignee: nobody → florian
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.1
You need to log in before you can comment on or make changes to this bug.