Messages randomly getting lost in the background

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

trunk
x86
Windows 7

Details

(Reporter)

Description

5 years ago
*** Original post on bio 1076 by Eric Caron <eric.caron AT gmail.com> at 2011-10-14 19:18:00 UTC ***

1. Have Instantbird open, but conversation window is not visible (bug occus when behind window, minimized or in system tray)

2. Incoming message is received, message notification scrolls into view and scrolls out of view.

3. New message does not show in task bar. I am only informed that it exists when trying to close Instantbird and am informed that there are unread conversations.

I've disabled the MSN plugin, and tried every option under "System Tray Icon," yet the problem persists. Messages have been backgrounded from Google, XMPP, AIM & MSN. I cannot reliably reproduce the problem but am still working on it.

(clokep pointed out that this ticket should be made in case others have this problem)
*** Original post on bio 1076 at 2011-10-14 20:36:28 UTC ***

Just to be sure we aren't missing something obvious here, you have verified that the preference "Flash the taskbar item" is checked, right? :-)
(Reporter)

Comment 2

5 years ago
*** Original post on bio 1076 by Eric Caron <eric.caron AT gmail.com> at 2011-10-14 20:38:22 UTC ***

Yes, it is checked. The message is not on the taskbar at all.
*** Original post on bio 1076 at 2011-12-06 10:33:47 UTC ***

So the problem is that the taskbar item for the conversation window is not flashing while it should?

I'll change the summary accordingly if that's the case.
(Reporter)

Comment 4

5 years ago
*** Original post on bio 1076 by Eric Caron <eric.caron AT gmail.com> at 2011-12-06 13:38:20 UTC ***

No, the problem is that the taskbar item does not even exist and there is no way to access the missing chat window except as described in my third step.

Comment 5

5 years ago
*** Original post on bio 1076 at 2012-06-25 13:25:23 UTC ***

"the taskbar item does not even exist" Does that mean that
- the new message is in a new tab in an existing conversation window (which is listed in the taskbar), so you can't tell from the taskbar that there are new messages there?
- there should be an entirely new window because your settings are to open new conversations in new windows, but there is no new window?

Does the recently introduced ruler above the unread messages mitigate this problem?
(Reporter)

Comment 6

5 years ago
*** Original post on bio 1076 by Eric Caron <eric.caron AT gmail.com> at 2012-06-25 13:44:52 UTC ***

(In reply to comment #5)
> "the taskbar item does not even exist" Does that mean that
> - the new message is in a new tab in an existing conversation window (which is
> listed in the taskbar), so you can't tell from the taskbar that there are new
> messages there?
> - there should be an entirely new window because your settings are to open new
> conversations in new windows, but there is no new window?
> 
> Does the recently introduced ruler above the unread messages mitigate this
> problem?

I mean "there should be an entirely new window because your settings are to open new conversations in new windows, but there is no new window."

Honestly I've switched IM clients because I got exhausted by the statement "the message is not on the taskbar at all" not being clear enough to developers.
*** Original post on bio 1076 at 2012-06-26 11:54:07 UTC ***

I've tried to reproduce this again but haven't had any luck. The steps I followed were:
1. Open Instantbird.
2. Connect my GMail account.
3. Minimized the Contact List window to the system tray using the File menu.
4. Sent an IM to myself from the GMail web interface.

Results:
1. Window pops up (over everything I'm doing == annoying).
2. Taskbar flashes.
3. Sound plays.

I also tried this if I already had a chat open but in the background and minimized; also with the contact list open and in the background. Nothing seems able to reproduce this. :(

Comment 8

5 years ago
*** Original post on bio 1076 at 2012-06-26 11:56:45 UTC ***

(In reply to comment #6)
> (In reply to comment #5)
> > "the taskbar item does not even exist" Does that mean that
> > - the new message is in a new tab in an existing conversation window (which is
> > listed in the taskbar), so you can't tell from the taskbar that there are new
> > messages there?
> > - there should be an entirely new window because your settings are to open new
> > conversations in new windows, but there is no new window?
> 
> I mean "there should be an entirely new window because your settings are to
> open new conversations in new windows, but there is no new window."
> 
> Honestly I've switched IM clients because I got exhausted by the statement "the
> message is not on the taskbar at all" not being clear enough to developers.

I asked those questions because I could not reproduce on Linux, and wanted to make sure I hadn't misunderstood anything.
*** Original post on bio 1076 at 2013-03-05 08:42:24 UTC ***

I've heard an incoming message yesterday [1] but it was nowhere to be found. It turned out that it should have appeared in #instantbird's tab but it never did.
This lost message seems to be related to re-ordering conversation tabs by dragging and dropping them between different windows. Flo has seen this and that was what I had done minutes before the problem too.

Eric, could it be that you've also moved tabs between windows before seeing this problem? It's long ago but maybe you know anyways, e.g. because that's what you are/were usually doing?

Thanks a lot in advance, maybe we'll finally be able to figure this out! :)


[1] http://log.bezut.info/instantbird/130304/#m206
(Reporter)

Comment 10

5 years ago
*** Original post on bio 1076 by eric.caron AT gmail.com at 2013-03-05 14:19:55 UTC ***

At the time it happened, I didn't have IRC enabled. I've since moved off Windows so I can't reproduce it. Since nobody else has experienced the original bug I mentioned, I'm just going to close this ticket.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.