Closed Bug 954614 Opened 6 years ago Closed 6 years ago

"Reference to undefined property" JS warnings

Categories

(Instantbird :: Other, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aleth, Assigned: aleth)

References

Details

(Whiteboard: [1.2-wanted])

Attachments

(10 files, 7 obsolete files)

514 bytes, patch
florian
: review-
Details | Diff | Splinter Review
591 bytes, patch
aleth
: review-
Details | Diff | Splinter Review
1.79 KB, patch
florian
: review+
Details | Diff | Splinter Review
2.27 KB, patch
Details | Diff | Splinter Review
484 bytes, patch
florian
: review-
Details | Diff | Splinter Review
705 bytes, patch
florian
: review+
Details | Diff | Splinter Review
409 bytes, patch
florian
: review+
Details | Diff | Splinter Review
499 bytes, patch
florian
: review+
Details | Diff | Splinter Review
677 bytes, patch
florian
: review-
Details | Diff | Splinter Review
1.20 KB, patch
clokep
: review+
Details | Diff | Splinter Review
*** Original post on bio 1182 at 2011-11-22 22:33:00 UTC ***

The update to mozilla 9 (bug 954593 (bio 1161)) brought with it new warnings due to undefined default property values. These will be collected here.

Warning: reference to undefined property this._findField
Source File: chrome://global/content/bindings/findbar.xml
Line: 309

Warning: reference to undefined property this.mCurrentConversation
Source File: chrome://instantbird/content/tabbrowser.xml
Line: 262

Warning: reference to undefined property this._showOffline
Source File: chrome://instantbird/content/group.xml
Line: 113

Warning: reference to undefined property Components.classes['@mozilla.org/privatebrowsing;1']
Source File: chrome://global/content/globalOverlay.js
Line: 17

Warning: reference to undefined property types[type]
Source File: chrome://mozapps/content/extensions/extensions.js
Line: 1480

Warning: reference to undefined property this.disableTimerID
Source File: chrome://instantbird/content/accounts.js
Line: 373

Warning: reference to undefined property this.reconnectUpdateInterval
Source File: chrome://instantbird/content/account.xml
Line: 207

Warning: reference to undefined property this._connectedLabelInterval
Source File: chrome://instantbird/content/accounts.js
Line: 97

Warning: reference to undefined property json._dataType
Source File: jar:file://instantbird/omni.jar!/components/nsSearchService.js
Line: 2698

Warning: reference to undefined property this._textSelected
Source File: resource:///modules/imThemes.jsm
Line: 866
Blocks: 954593
Depends on: 954615
Depends on: 954616
*** Original post on bio 1182 at 2011-11-23 00:14:35 UTC ***

Some more:

JavaScript strict warning: chrome://instantbird/content/conversation.xml, line 1354: reference to undefined property this._conv

JavaScript strict warning: file:///.../InstantbirdDebug.app/Contents/MacOS/components/nsContentPrefService.js, line 140: reference to undefined property Cc['@mozilla.org/privatebrowsing;1']
*** Original post on bio 1182 at 2011-11-23 04:51:24 UTC ***

(In reply to comment #0)
> Warning: reference to undefined property this._findField
> Source File: chrome://global/content/bindings/findbar.xml
> Line: 309
Checked in as http://hg.instantbird.org/instantbird/rev/a0365b25ff14
*** Original post on bio 1182 at 2011-11-23 20:46:52 UTC ***

Warning: reference to undefined property this._buddy
Source File: chrome://instantbird/content/buddytooltip.xml
Line: 0
*** Original post on bio 1182 at 2011-11-23 21:26:23 UTC ***

Warning: reference to undefined property this._topicKeyPress
Source File: chrome://instantbird/content/conversation.xml
Line: 1467
*** Original post on bio 1182 at 2011-11-24 11:12:49 UTC ***

JavaScript strict warning: chrome://instantbird/content/accountWizard.js, line 140: reference to undefined property this.userNameProto

JavaScript strict warning: chrome://instantbird/content/accountWizard.js, line 196: reference to undefined property this.protoSpecOptId
*** Original post on bio 1182 at 2011-11-24 11:55:05 UTC ***

JavaScript strict warning: resource:///modules/jsProtoHelper.jsm, line 651: reference to undefined property option.masked
*** Original post on bio 1182 as attmnt 1021 at 2011-11-25 20:40:00 UTC ***

The conversation.xml ones look straightforward.
Attachment #8352763 - Flags: review?(florian)
Attached patch Patch for buddytooltip.xml (obsolete) — Splinter Review
*** Original post on bio 1182 as attmnt 1022 at 2011-11-25 20:49:00 UTC ***

Being a bit proactive on this one - please check!
Attachment #8352764 - Flags: review?(florian)
*** Original post on bio 1182 at 2011-11-25 21:01:53 UTC ***

Another one of these:

Warning: reference to undefined property Cc['@mozilla.org/privatebrowsing;1']
Source File: file:///instantbird/components/nsContentPrefService.js
Line: 140
*** Original post on bio 1182 as attmnt 1023 at 2011-11-25 22:12:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352765 - Flags: review?(florian)
Attached patch Patch for account.xml (obsolete) — Splinter Review
*** Original post on bio 1182 as attmnt 1024 at 2011-11-25 22:39:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352766 - Flags: review?(florian)
Attached patch Patch for accounts.js (obsolete) — Splinter Review
*** Original post on bio 1182 as attmnt 1025 at 2011-11-25 22:46:00 UTC ***

Deleting a property causes it to be undefined later ;)
Attachment #8352767 - Flags: review?(florian)
Attached patch Patch for imThemes.jsm (obsolete) — Splinter Review
*** Original post on bio 1182 as attmnt 1026 at 2011-11-25 23:01:00 UTC ***

Original code uses absence of the property to check whether it has been initialized or not. In a way the fix is less elegant.
Attachment #8352768 - Flags: review?(florian)
*** Original post on bio 1182 as attmnt 1027 at 2011-11-26 00:24:00 UTC ***

The unload listener needed to have the object bound to it for "this" to be correctly defined.
Attachment #8352769 - Flags: review?(florian)
Comment on attachment 8352767 [details] [diff] [review]
Patch for accounts.js

*** Original change on bio 1182 attmnt 1025 at 2011-11-26 00:24:08 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352767 - Attachment is obsolete: true
Attachment #8352767 - Flags: review?(florian)
*** Original post on bio 1182 at 2011-11-27 22:56:30 UTC ***

Warning: reference to undefined property this._stopEditDisplayNameTimeout
Source File: chrome://instantbird/content/blist.js
Line: 589
*** Original post on bio 1182 at 2011-11-29 22:11:20 UTC ***

"JavaScript strict warning: chrome://instantbird/content/accounts.js, line 617: reference to undefined property this._accountElement"
*** Original post on bio 1182 as attmnt 1038 at 2011-11-29 22:17:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352780 - Flags: review?(florian)
Comment on attachment 8352769 [details] [diff] [review]
Patch for accounts.js

*** Original change on bio 1182 attmnt 1027 at 2011-11-29 22:17:55 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352769 - Attachment is obsolete: true
Attachment #8352769 - Flags: review?(florian)
Comment on attachment 8352769 [details] [diff] [review]
Patch for accounts.js

*** Original change on bio 1182 attmnt 1027 at 2011-11-29 22:30:08 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352769 - Flags: review+
Comment on attachment 8352780 [details] [diff] [review]
Patch for accounts.js

*** Original change on bio 1182 attmnt 1038 at 2011-11-29 22:35:33 UTC ***

We just discussed on IRC another way to address the warning in comment 16. The other changes were in attachment 8352769 [details] [diff] [review] (bio-attmnt 1027) which I've just r+'ed.
Attachment #8352780 - Flags: review?(florian)
Comment on attachment 8352769 [details] [diff] [review]
Patch for accounts.js

*** Original change on bio 1182 attmnt 1027 at 2011-11-29 22:36:13 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352769 - Attachment is obsolete: false
Comment on attachment 8352766 [details] [diff] [review]
Patch for account.xml

*** Original change on bio 1182 attmnt 1024 at 2011-11-29 22:55:59 UTC ***

This doesn't really fix the bug, as there are 2 delete this.reconnectUpdateInterval; instructions in the same file. We agreed on another fix on IRC.
Attachment #8352766 - Flags: review?(florian) → review-
Comment on attachment 8352763 [details] [diff] [review]
Patch for conversation.xml

*** Original change on bio 1182 attmnt 1021 at 2011-11-29 23:48:14 UTC ***

I don't believe this patch actually fixes the warnings it attempts to fix. We discussed another fix on IRC.
Attachment #8352763 - Flags: review?(florian) → review-
Comment on attachment 8352764 [details] [diff] [review]
Patch for buddytooltip.xml

*** Original change on bio 1182 attmnt 1022 at 2011-11-30 00:01:33 UTC ***

The |bundle| and |rows| properties have "smart" getters, so the changes on them are clearly wrong.

I don't know about the changes for the buddy, contact and elt properties. I've no idea of the steps to reproduce the warning you are attempting to fix in this patch, so I can't check if there's a bug in the calling code. If there isn't then the changes on these properties are right.
Attachment #8352764 - Flags: review?(florian) → review-
*** Original post on bio 1182 as attmnt 1039 at 2011-11-30 09:42:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352781 - Flags: review?(florian)
Comment on attachment 8352768 [details] [diff] [review]
Patch for imThemes.jsm

*** Original change on bio 1182 attmnt 1026 at 2011-11-30 09:42:43 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352768 - Attachment is obsolete: true
Attachment #8352768 - Flags: review?(florian)
*** Original post on bio 1182 as attmnt 1040 at 2011-11-30 11:34:00 UTC ***

The problem here was that _buddy is undefined for nicklist participants.
The default value is appropriate since these three vars are set to null by the popuphiding method.
Attachment #8352782 - Flags: review?(florian)
Comment on attachment 8352764 [details] [diff] [review]
Patch for buddytooltip.xml

*** Original change on bio 1182 attmnt 1022 at 2011-11-30 11:34:36 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352764 - Attachment is obsolete: true
*** Original post on bio 1182 at 2011-11-30 11:45:36 UTC ***

What's left:

Warning: reference to undefined property
Components.classes['@mozilla.org/privatebrowsing;1']
Source File: chrome://global/content/globalOverlay.js
Line: 17

Warning: reference to undefined property Cc['@mozilla.org/privatebrowsing;1']
Source File: file:///instantbird/components/nsContentPrefService.js
Line: 140

file:///.../InstantbirdDebug.app/Contents/MacOS/components/nsContentPrefService.js,
line 140: reference to undefined property Cc['@mozilla.org/privatebrowsing;1']


Warning: reference to undefined property types[type]
Source File: chrome://mozapps/content/extensions/extensions.js
Line: 1480

Warning: reference to undefined property this._stopEditDisplayNameTimeout
Source File: chrome://instantbird/content/blist.js
Line: 589

JavaScript strict warning: resource:///modules/jsProtoHelper.jsm, line 651:
reference to undefined property option.masked
*** Original post on bio 1182 as attmnt 1042 at 2011-11-30 11:58:00 UTC ***

TimeOut only ever gets set after attempting to remove the previous one. A default value is cheaper than an if clause.
Attachment #8352784 - Flags: review?(florian)
*** Original post on bio 1182 at 2011-11-30 12:32:42 UTC ***

The jsProtoHelper.jsm warning will be due to one of the protocols not setting masked. Hard to know which one, so one should come back to this after the warning has been reproduced.
Attached patch Patch (obsolete) — Splinter Review
*** Original post on bio 1182 as attmnt 1056 at 2011-12-05 22:19:00 UTC ***

Corrects oversight in previous committed fix.
Attachment #8352798 - Flags: review?(florian)
Comment on attachment 8352766 [details] [diff] [review]
Patch for account.xml

*** Original change on bio 1182 attmnt 1024 at 2011-12-05 22:19:57 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352766 - Attachment is obsolete: true
Attached patch Patch for account.xml (obsolete) — Splinter Review
*** Original post on bio 1182 as attmnt 1057 at 2011-12-05 22:33:00 UTC ***

Corrected fix.
Attachment #8352799 - Flags: review?(florian)
Comment on attachment 8352798 [details] [diff] [review]
Patch

*** Original change on bio 1182 attmnt 1056 at 2011-12-05 22:33:38 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352798 - Attachment is obsolete: true
Attachment #8352798 - Flags: review?(florian)
Attached patch Patch for account.xml (obsolete) — Splinter Review
*** Original post on bio 1182 as attmnt 1058 at 2011-12-05 22:36:00 UTC ***

Undoing overkill. Sorry for the bugspam.
Attachment #8352800 - Flags: review?(florian)
Comment on attachment 8352799 [details] [diff] [review]
Patch for account.xml

*** Original change on bio 1182 attmnt 1057 at 2011-12-05 22:36:45 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352799 - Attachment is obsolete: true
Attachment #8352799 - Flags: review?(florian)
*** Original post on bio 1182 as attmnt 1060 at 2011-12-05 23:54:00 UTC ***

Correct spacing
Attachment #8352802 - Flags: review?(florian)
Comment on attachment 8352800 [details] [diff] [review]
Patch for account.xml

*** Original change on bio 1182 attmnt 1058 at 2011-12-05 23:54:14 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352800 - Attachment is obsolete: true
Attachment #8352800 - Flags: review?(florian)
Comment on attachment 8352765 [details] [diff] [review]
Patch for accountWizard.js

*** Original change on bio 1182 attmnt 1023 at 2011-12-07 23:43:28 UTC ***

Better version committed by flo.
Attachment #8352765 - Flags: review?(florian) → review-
*** Original post on bio 1182 at 2011-12-08 10:13:24 UTC ***

(In reply to comment #31)
> Comment on attachment 8352765 [details] [diff] [review] (bio-attmnt 1023) [details]
> Patch for accountWizard.js
> 
> Better version committed by flo.

This was https://hg.instantbird.org/instantbird/rev/bcd48c42b970
*** Original post on bio 1182 at 2011-12-09 02:32:09 UTC ***

I just got this while testing JS-IRC:
Warning: reference to undefined property Services.core.globalUserStatus.statusMessage
Source File: chrome://instantbird/content/blist.js
Line: 479
Comment on attachment 8352782 [details] [diff] [review]
Patch for buddytooltip.xml

*** Original change on bio 1182 attmnt 1040 at 2011-12-11 21:33:55 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352782 - Flags: review?(florian) → review+
Comment on attachment 8352784 [details] [diff] [review]
Patch for blist.js

*** Original change on bio 1182 attmnt 1042 at 2011-12-11 21:38:03 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352784 - Flags: review?(florian) → review+
Comment on attachment 8352802 [details] [diff] [review]
Patch for account.xml

*** Original change on bio 1182 attmnt 1060 at 2011-12-11 21:39:41 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8352802 - Flags: review?(florian) → review+
Comment on attachment 8352781 [details] [diff] [review]
Patch for imThemes.jsm

*** Original change on bio 1182 attmnt 1039 at 2011-12-11 21:59:47 UTC ***

We discussed some additional changes needed for _cutBegin/End on IRC.
Attachment #8352781 - Flags: review?(florian) → review-
*** Original post on bio 1182 at 2011-12-12 01:13:55 UTC ***

(In reply to comment #33)
> I just got this while testing JS-IRC:
> Warning: reference to undefined property
> Services.core.globalUserStatus.statusMessage
> Source File: chrome://instantbird/content/blist.js
> Line: 479

Checked in as http://hg.instantbird.org/instantbird/rev/d367be2a2eb8

(In reply to comment #23)
> Created attachment 8352782 [details] [diff] [review] (bio-attmnt 1040) [details]
> Patch for buddytooltip.xml

(In reply to comment #25)
> Created attachment 8352784 [details] [diff] [review] (bio-attmnt 1042) [details]
> Patch for blist.js

(In reply to comment #30)
> Created attachment 8352802 [details] [diff] [review] (bio-attmnt 1060) [details]
> Patch for account.xml

Checked in as http://hg.instantbird.org/instantbird/rev/344ecd3a4d7c
*** Original post on bio 1182 at 2011-12-12 10:15:35 UTC ***

(In reply to comment #34)
> Comment on attachment 8352781 [details] [diff] [review] (bio-attmnt 1039) [details]
> Patch for imThemes.jsm
> 
> We discussed some additional changes needed for _cutBegin/End on IRC.

Done in https://hg.instantbird.org/instantbird/rev/623feed8b5e6
*** Original post on bio 1182 at 2012-01-03 18:10:57 UTC ***

Some new ones, possibly related to the JSON logs patch.

Warning: reference to undefined property FullZoom._value
Source File: chrome://instantbird/content/convZoom.js
Line: 116

Warning: reference to undefined property aMsg.conversation.account
Source File: resource:///modules/imThemes.jsm
Line: 428

Warning: reference to undefined property aMessage[f]
Source File: jar:file:///home/john/instantbird/omni.jar!/components/logger.js
Line: 184
*** Original post on bio 1182 at 2012-01-29 11:12:37 UTC ***

Warning: reference to undefined property this.selected
Source File: jar:file://instantbird/omni.jar!/components/nsUpdateService.js
Line: 605

Warning: reference to undefined property this.installDate
Source File: jar:file://instantbird/omni.jar!/components/nsUpdateService.js
Line: 798

Some from mozilla:

Warning: reference to undefined property this.update.billboardURL
Source File: chrome://mozapps/content/update/updates.js
Line: 573

Warning: reference to undefined property gUpdates.update.licenseURL
Source File: chrome://mozapps/content/update/updates.js
Line: 662

Warning: reference to undefined property this.treeBoxObject.view
Source File: chrome://global/content/bindings/tree.xml
Line: 0

Would be nice to resolve this bug for 1.2 (with at least the non-mozilla ones fixed) as it is getting a bit unwieldy.
Whiteboard: [1.2-wanted]
*** Original post on bio 1182 at 2012-01-29 12:57:15 UTC ***

Warning: reference to undefined property aEvent.button
Source File: chrome://instantbird/content/mintrayr.js
Line: 104
*** Original post on bio 1182 at 2012-01-29 21:43:23 UTC ***

(In reply to comment #39)
> Warning: reference to undefined property aEvent.button
> Source File: chrome://instantbird/content/mintrayr.js
> Line: 104

This one was due to v1 of the (unlanded) patch for bug 954302 (bio 869).
*** Original post on bio 1182 at 2012-01-30 12:22:03 UTC ***

Remaining non-mozilla warnings with reproduction step:


Add-on updater:

Warning: reference to undefined property types[type]
Source File: chrome://mozapps/content/extensions/extensions.js
Line: 1480


JSON log viewer:

Warning: reference to undefined property FullZoom._value
Source File: chrome://instantbird/content/convZoom.js
Line: 116


IB Updater:

Warning: reference to undefined property this.selected
Source File: jar:file://instantbird/omni.jar!/components/nsUpdateService.js
Line: 605

Warning: reference to undefined property this.installDate
Source File: jar:file://instantbird/omni.jar!/components/nsUpdateService.js
Line: 798


JS-IRC (?)

Warning: reference to undefined property
Services.core.globalUserStatus.statusMessage
Source File: chrome://instantbird/content/blist.js
Line: 479
*** Original post on bio 1182 at 2012-01-30 13:34:49 UTC ***

(In reply to comment #41)
> Remaining non-mozilla warnings with reproduction step:
> 
> 
> Add-on updater:
> 
> Warning: reference to undefined property types[type]
> Source File: chrome://mozapps/content/extensions/extensions.js
> Line: 1480

> 
> IB Updater:
> 
> Warning: reference to undefined property this.selected
> Source File: jar:file://instantbird/omni.jar!/components/nsUpdateService.js
> Line: 605
> 
> Warning: reference to undefined property this.installDate
> Source File: jar:file://instantbird/omni.jar!/components/nsUpdateService.js
> Line: 798

chrome://mozapps/content/extensions/extensions.js and components/nsUpdateService.js are files from the Mozilla toolkit.


> JS-IRC (?)
> 
> Warning: reference to undefined property
> Services.core.globalUserStatus.statusMessage
> Source File: chrome://instantbird/content/blist.js
> Line: 479

I fixed this in https://hg.instantbird.org/instantbird/rev/d367be2a2eb8, it was a real bug.
*** Original post on bio 1182 as attmnt 1143 at 2012-01-30 23:12:00 UTC ***

(In reply to comment #41)
In the interest of closing this bug... ;)

> Warning: reference to undefined property FullZoom._value
> Source File: chrome://instantbird/content/convZoom.js
> Line: 116

FullZoom is not initialized the first time FullZoom.setSettingValue is called here. Add an explicit call to get the value from the pref to fix this. What I don't quite understand is why changing the zoom factor still works if one instead removes FullZoom.setSettingValue (line 91) altogether. (If I understood this it could be an alternative fix.)
Attachment #8352888 - Flags: review?(florian)
*** Original post on bio 1182 at 2012-01-31 10:15:47 UTC ***

(In reply to comment #43)
> What I don't quite understand is why changing the zoom factor still works if 
> one instead removes FullZoom.setSettingValue (line 91) altogether.

I should rephrase that: I don't understand the reason for line 91 (because FullZoom initializes itself), but there must have been one, right?
Comment on attachment 8352888 [details] [diff] [review]
Patch for viewlog.js

*** Original change on bio 1182 attmnt 1143 at 2012-01-31 15:42:45 UTC ***

We discussed a larger cleanup of that file over IRC this morning.

(In reply to comment #43)
> What I
> don't quite understand is why changing the zoom factor still works if one
> instead removes FullZoom.setSettingValue (line 91) altogether. (If I understood
> this it could be an alternative fix.)

The trick with that code is that there are 2 different browsers in the log viewer, one for plain text logs and one for conversations. Line 91 is needed if you select a conversation after having changed the zoom level while a plain text log was selected.
Attachment #8352888 - Flags: review?(florian) → review-
*** Original post on bio 1182 at 2012-02-03 19:38:01 UTC ***

(In reply to comment #45)
> We discussed a larger cleanup of that file over IRC this morning.

Landed in https://hg.instantbird.org/instantbird/rev/c06a991d108f.

All remaining warnings are in mozilla code. Since this bug is getting a bit long, filing those as a new bug 954688 (bio 1257), in case anybody wants to tackle some of them in the future.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
*** Original post on bio 1182 as attmnt 1165 at 2012-02-10 00:17:00 UTC ***

Warning: reference to undefined property this.changeTargetCommand, Source File: chrome://instantbird/content/conversation.xml, Line: 1612
Attachment #8352910 - Flags: review?(florian)
Assignee: nobody → aleth
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8352910 [details] [diff] [review]
Another patch for conversation.xml

*** Original change on bio 1182 attmnt 1165 at 2012-04-23 23:58:39 UTC ***

So I couldn't figure out exactly how to reproduce this warning...but this change seems fine to me.
Attachment #8352910 - Flags: review?(florian) → review+
Whiteboard: [1.2-wanted] → [1.2-wanted][checkin-needed]
*** Original post on bio 1182 at 2012-04-26 00:12:44 UTC ***

(In reply to comment #47)
> Created attachment 8352910 [details] [diff] [review] (bio-attmnt 1165) [details]
> Another patch for conversation.xml
> 
> Warning: reference to undefined property this.changeTargetCommand, Source File:
> chrome://instantbird/content/conversation.xml, Line: 1612

Checked in as http://hg.instantbird.org/instantbird/rev/822fabca6367

If we see more of these, let's open a new bug.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Whiteboard: [1.2-wanted][checkin-needed] → [1.2-wanted]
*** Original post on bio 1182 at 2012-06-06 16:27:42 UTC ***

(In reply to comment #24)
> What's left:
> 
> Warning: reference to undefined property
> Components.classes['@mozilla.org/privatebrowsing;1']
> Source File: chrome://global/content/globalOverlay.js
> Line: 17

Fixed for Mozilla 15 in https://bugzilla.mozilla.org/show_bug.cgi?id=748889

> Warning: reference to undefined property Cc['@mozilla.org/privatebrowsing;1']
> Source File: file:///instantbird/components/nsContentPrefService.js
> Line: 140

I've just filed https://bugzilla.mozilla.org/show_bug.cgi?id=762088 to fix this.
*** Original post on bio 1182 at 2012-06-07 14:45:46 UTC ***

(In reply to comment #50)

> > Warning: reference to undefined property Cc['@mozilla.org/privatebrowsing;1']
> > Source File: file:///instantbird/components/nsContentPrefService.js
> > Line: 140
> 
> I've just filed https://bugzilla.mozilla.org/show_bug.cgi?id=762088 to fix
> this.

Fixed for Mozilla 16.
You need to log in before you can comment on or make changes to this bug.