Show Log Folder Button not opening a File Manager

RESOLVED INVALID

Status

Instantbird
Preferences
--
minor
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Instantbot, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
*** Original post on bio 1188 by Xavior Penguin <xavior.penguin AT gmail.com> at 2011-11-30 02:05:00 UTC ***

OS: xubuntu 11.10
Instantbird Version: 1.1 Stable
Issue: Going to Tools -> Preferences -> Privacy -> Show Log Folder...
Clicking that button opens up xubuntu's dialog box stating that it doesn't know how to handle links.  Locating the default file manager for xubuntu, Thunar, in /usr/bin/Thunar and making it associate with Instantbird fixes the issue slightly.

Doing the above, it opens up /home/USER/.instantbird/RANDOM.default folder where USER is your login and RANDOM is the random number string for the default profile for instantbird.  It does not go into the logs folder at all.

Comment 1

5 years ago
*** Original post on bio 1188 at 2011-11-30 16:14:34 UTC ***

Works for me on Mandriva. It's supposed to use whatever file manager your OS has, with the subtlety that for me on KDE it opens Nautilus (not Dolphin) because Instantbird is a gtk app. So it's possible it was your xubuntu configuration which was at first lacking the required information.

Regarding the second point, is it possible you didn't have any logs yet when you tried this - maybe the folder did not exist yet?
*** Original post on bio 1188 at 2011-11-30 17:28:33 UTC ***

I was the one who added that button in first place and used code from Firefox for this. It seems to jump through some hoops for *ix systems.

Here's the check-in:

http://hg.instantbird.org/instantbird/rev/e35b6c9861f5


Here's the (apparantly now updated) code in mxr - maybe we could do something better today than we did back then? - I haven't checked yet.

http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/downloads/content/downloads.js#252
(Reporter)

Comment 3

5 years ago
*** Original post on bio 1188 by Xavior Penguin <xavior.penguin AT gmail.com> at 2011-11-30 20:23:55 UTC ***

aleth: I know you are right on that.  I bet if I reinstall xubuntu (which I ain't), I would probably get the thing to popup properly.

Regarding the logs, I don't know.  I know that after I put in the association to Thunar (default file manager) that the folder was listed right there.  I will try again tonight to see if it in fact does go to the logs folder.

Got another issue very similar to this, going to try to replicate it once I get back into my xubuntu cause it doesn't appear in Windows.

Comment 4

5 years ago
*** Original post on bio 1188 at 2012-02-13 19:40:35 UTC ***

I don't think this was an IB issue, as per comment 2. Resolving as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.