Closed Bug 954693 Opened 7 years ago Closed 7 years ago

[Accessibility] Add aria attributes to conversation views and contact groups

Categories

(Instantbird :: Conversation, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: benediktp, Assigned: florian)

Details

Attachments

(1 file)

*** Original post on bio 1262 at 2012-02-10 10:30:00 UTC ***

Atleast our default messagestyle themes should be accessible, maybe even all themes (i.e. we automatically insert the correct attribute from imThemes.jsm).

This was fixed by bug 953554 (bio 103) already and suffered a regression one day.


There was a few lines about this on IRC one day (http://log.bezut.info/instantbird/111215/#m156):

20:52:34 <bp> Concerning themes and accessibility: what about adding the aria-attributes to all the themes we ship (or to Bubbles at leastas it is the default theme)?
[...]
20:55:29 <flo> bp: I think I commented in that bug that we could either add the accessibility attributes automatically on the message <span> tag in imThemes.jsm so that all themes automatically have it, or decide that blind users are unlikely to change the theme they use, and just add the tags in the default theme
*** Original post on bio 1262 by Peter Vagner <pvdeejay AT gmail.com> at 2012-04-18 13:05:54 UTC ***

Hello,
I am always adding aria-live="polite" attribute to the body tag in imThemes.jsm.
But I think this is not the correct solution because this feature is then also enabled for log viewer preview window inside the options dialog etc.
Ideally this should only be available in the conversation window where updates are expected.
I am not sure if the place where I am putting it to is the proper one too but I haven't found issues with it so far. I am using it this way for several months now.
*** Original post on bio 1262 at 2012-04-18 13:14:51 UTC ***

Note: https://bugzilla.mozilla.org/show_bug.cgi?id=739599 is almost the same bug filed for Thunderbird.
Attached patch PatchSplinter Review
*** Original post on bio 1262 as attmnt 1605 at 2012-06-14 14:36:00 UTC ***

Port the changes from:
https://bugzilla.mozilla.org/show_bug.cgi?id=739644 - add aria-expanded attributes to group bindings
https://bugzilla.mozilla.org/show_bug.cgi?id=739599 - add aria-live="polite" to the whole Chat div instead of doing it per message theme. This fixes the bug described here.

I also removed the left over aria-live="polite" in the simple theme.
Attachment #8353362 - Flags: review?(clokep)
Assignee: nobody → florian
Comment on attachment 8353362 [details] [diff] [review]
Patch

*** Original change on bio 1262 attmnt 1605 at 2012-06-14 14:39:06 UTC ***

(In reply to comment #3)
> https://bugzilla.mozilla.org/show_bug.cgi?id=739599 - add aria-live="polite" to
> the whole Chat div instead of doing it per message theme. This fixes the bug
> described here.

I could have sworn you had checked this in already in Instantbird, but I guess not...
Attachment #8353362 - Flags: review?(clokep) → review+
*** Original post on bio 1262 at 2012-06-15 00:37:32 UTC ***

Checked in as http://hg.instantbird.org/instantbird/rev/d4015a1d51f1

Thanks for porting those patches Florian. :)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.2
*** Original post on bio 1262 at 2012-07-18 08:19:34 UTC ***

Matching summary to the commit message.
Summary: [Accessibility] Make (default?) messagestyle themes accessible → [Accessibility] Add aria attributes to conversation views and contact groups
You need to log in before you can comment on or make changes to this bug.