Closed Bug 954715 Opened 9 years ago Closed 2 years ago

Ability to block / report as spam for Twitter messages

Categories

(Chat Core :: Twitter, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: clokep, Unassigned, Mentored)

References

()

Details

(Keywords: good-first-bug)

*** Original post on bio 1283 at 2012-02-25 20:43:00 UTC ***

We should add actions to the context menu for Twitter messages to be able to block a user / mark a user as spam. Occasionally I get @-messages from people I don't follow with sketchy links and I'd like to do my part to report those people.
Duplicate of this bug: 954625
*** Original post on bio 1283 at 2013-04-17 05:12:47 UTC ***

I would love some starting pointers in lunch. ;-)
*** Original post on bio 1283 at 2013-04-17 09:34:17 UTC ***

(In reply to comment #2)
> I would love some starting pointers in lunch. ;-)

The Twitter API documentation is here: https://dev.twitter.com/docs/api/1.1

You may find it useful to look at how follow/unfollow are implemented, e.g.
http://lxr.instantbird.org/instantbird/source/chat/protocols/twitter/twitter.js#37
http://lxr.instantbird.org/instantbird/source/chat/protocols/twitter/twitter.js#529
Whiteboard: [mentor=clokep][good first bug]
Mentor: clokep
Whiteboard: [mentor=clokep][good first bug] → [good first bug]
Keywords: good-first-bug
Whiteboard: [good first bug]

Bug 1445778 removes support for Twitter due to changes in their streaming API.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.