Increase discoverability of changing the network in use to talk to a contact

RESOLVED WORKSFORME

Status

Instantbird
Conversation
--
enhancement
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Instantbot, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
*** Original post on bio 1289 by Tomáš Komárek <tomaskom.cz AT seznam.cz> at 2012-02-26 02:12:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
(Reporter)

Comment 1

4 years ago
Created attachment 8352951 [details]
rough draft of proposed change

*** Original post on bio 1289 as attmnt 1200 by tomaskom.cz AT seznam.cz at 2012-02-26 02:12:00 UTC ***

At the moment, there is only currently used protocol shown as a clickable icon in conversation window. 

I think it would be better to show all of them (of course handle extreme case somehow) in the unused space, the currently used one should be highlighted. It would give user info about status of other contacts (protocols) under the same metacontact at first glance. 

See attachement to understand what I mean.
*** Original post on bio 1289 at 2012-02-26 02:22:23 UTC ***

After discussion on IRC, the concern is about missing a contact when they sign off on the contact you're currently talking to but stay online with a different contact. I think bug 954176 (bio 742) is also of interest for this use case.
OS: Windows Vista → All
Hardware: x86 → All
(Reporter)

Comment 3

4 years ago
*** Original post on bio 1289 by Tomáš Komárek <tomaskom.cz AT seznam.cz> at 2012-02-26 03:11:01 UTC ***

It would solve the problem of automatic change proposed in bug 954176 (bio 742) by giving user easy control about what's happening without need for automatic changing, which carries many difficulties (how to decide to which protocol to change, ... just let the user say what to do and when to do it!). 
As Clokep mentioned on IRC, it would also enhance discoverability of easy changing between protocols. 

But it's not just about changing target when one of contact protocols goes off. User may decide to change target at any moment for any reason, eg. when more preffered one goes online. Generally, it gives _realtime info_ about status of all subcontacts and easier way for user to decide which one of them to use.
*** Original post on bio 1289 at 2012-02-26 15:01:35 UTC ***

Several targets can have the same protocol, we can't assume each contact has only one account per protocol.

In the future I think it would be interesting to make each XMPP resource become a conversation target, so that the user can decide where the messages will be received (I think it's what people want when they say they want to select with protocol they use: they want to decide where the message will be received).
(Reporter)

Comment 5

4 years ago
*** Original post on bio 1289 by Tomáš Komárek <tomaskom.cz AT seznam.cz> at 2012-02-26 15:34:41 UTC ***

(In reply to comment #3)
> Several targets can have the same protocol, we can't assume each contact has
> only one account per protocol.

(when saying protocol, i meant subcontact sometimes)
I can't see any problem with that (at least any more than currently). Target name could be shown when hovered, and current target is always shown next to photo (and on the tab). 
At the moment there is no easy way to distinguish between two subcontacts of same protocol either. User has to click the button to compare two of the same protocol. Hovering seems no more difficult to me. Also Bug 954608 (bio 1176) can cause that there is no way to to distinguish them!
I think that it is ok if the target subcontact icons don't change positions (sorted as in contacts list) and name is shown on hover.


About XPMM resources, could be resolved easily with simple drop-down menu on click/hover as it is currently :)
*** Original post on bio 1289 at 2012-02-26 15:54:28 UTC ***

Is the real problem here that the current drop down isn't discoverable enough? (the only way to discover it is seeing the mouse cursor change when hovering it)

I don't see how I could benefit from having the status of several subcontact (as you call them; we often call them "buddy") displayed at once in the main conversation UI, but the "there are other online buddies for this contact" information may be useful (as an indication that clicking the protocol icon would show something).

Showing all the protocol icons all the time would add visual noise and I suspect it would cause some user confusion (+ we try to deemphasis the protocol icons compared to other more relevant information).
(Reporter)

Comment 7

4 years ago
*** Original post on bio 1289 by Tomáš Komárek <tomaskom.cz AT seznam.cz> at 2012-02-26 16:34:39 UTC ***

User can be a bit confused, but I consider user usually knows that he has more than one buddy in that contact and just understant what is going on if he is smart enough to discover the possibility to have more buddies in one contact. 
Of course, the current buddy should be highlighted better than in attachment 8352951 [details] (bio-attmnt 1200). 

From my point of view, it fixes more problems than it would create. Especially there will no longer be need for any auto changing of target buddy (Bug 954176 (bio 742)), which is "difficult to do the in the right way". 

So:
+ better visual control of the buddies and easy switching when needed (discoverability)
+ could imply WONTFIX for Bug 954176 (bio 742)
- interventions in the current simple design

If not recognized as wanted, an addon could make it? :-P
*** Original post on bio 1289 at 2012-04-13 15:49:30 UTC ***

(In reply to comment #5)
> Is the real problem here that the current drop down isn't discoverable enough?
> (the only way to discover it is seeing the mouse cursor change when hovering
> it)
Perhaps showing it more as a button with a chevron would help this?

> Showing all the protocol icons all the time would add visual noise and I
> suspect it would cause some user confusion (+ we try to deemphasis the protocol
> icons compared to other more relevant information).
I agree.

These seem like different ideas that each need their own bug.
(In reply to comment #6)
> So:
> + better visual control of the buddies and easy switching when needed
> (discoverability)
This could be solved in other ways (see above).

> + could imply WONTFIX for Bug 954176 (bio 742)
I disagree, autochanging is still wanted!

> - interventions in the current simple design
A big downside in my opinion. :(

> If not recognized as wanted, an addon could make it? :-P
Addons are always welcome!

Comment 9

4 years ago
*** Original post on bio 1289 at 2012-04-30 22:35:51 UTC ***

I do agree there is a discoverability problem currently for the account switcher. I remember only discovering it months after starting to use Instantbird because I spotted it in the code ;)
*** Original post on bio 1289 at 2012-05-02 14:44:21 UTC ***

Marking this as confirmed in that we somehow need to increase the discoverability of this icon.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Show more than just current protocol in conversation window → Increase discoverability of changing the network in use to talk to a contact
Bug 1004930 made this more discoverable by making it appear like a real button.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.