Error: Removing or updating a nick that is not in the room

RESOLVED FIXED in 1.2

Status

Chat Core
IRC
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aleth, Assigned: aleth)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

4 years ago
*** Original post on bio 1309 at 2012-03-02 12:30:00 UTC ***

A timing issue when a quit message arrives before all the nicks have been added to the conversation?

Error: [Exception... "'Cannot remove a buddy that was not in the room' when calling method: [nsIObserver::observe]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: resource:///modules/jsProtoHelper.jsm :: <TOP_LEVEL> :: line 441"  data: no]
Source File: resource:///modules/jsProtoHelper.jsm
Line: 441

Error: Error running command QUIT with handler RFC 2812:
{"rawMessage":":sunfun!~sunfun@2-226-13-101.ip178.fastwebnet.it QUIT :Ping timeout: 272 seconds","source":"sunfun!~sunfun@2-226-13-101.ip178.fastwebnet.it","command":"QUIT","params":["Ping timeout: 272 seconds"],"nickname":"sunfun","user":"~sunfun","host":"2-226-13-101.ip178.fastwebnet.it"}
Source File: resource:///modules/ircHandlers.jsm
Line: 117

Error: [Exception... "'Cannot remove a buddy that was not in the room' when calling method: [nsIObserver::observe]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: resource:///modules/jsProtoHelper.jsm :: <TOP_LEVEL> :: line 441"  data: no]
Source File: resource:///modules/ircHandlers.jsm
Line: 118

Warning: Unhandled IRC message: :sunfun!~sunfun@2-226-13-101.ip178.fastwebnet.it QUIT :Ping timeout: 272 seconds
Source File: jar:file:///instantbird/omni.jar!/components/irc.js
Line: 331
*** Original post on bio 1309 at 2012-03-22 11:43:58 UTC ***

Has this problem occured again?
(Assignee)

Comment 2

4 years ago
*** Original post on bio 1309 at 2012-04-12 22:54:55 UTC ***

This also happens:

Timestamp: 04/13/2012 12:48:51 AM
Error: [Exception... "'Updating a chat buddy that does not exist?!' when calling method: [nsIObserver::observe]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: resource:///modules/jsProtoHelper.jsm :: <TOP_LEVEL> :: line 443"  data: no]
Source File: resource:///modules/jsProtoHelper.jsm
Line: 443

(...)

I'm attaching it to this bug as it has the same sequence of three error messages. 

Due to a race condition maybe?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Error on joining #ubuntu: Removing a nick that is not in the room → Error: Removing or updating a nick that is not in the room
(Assignee)

Comment 3

4 years ago
*** Original post on bio 1309 at 2012-04-13 14:02:14 UTC ***

This does not only happen when joining a room. It may simply be a consequence of breakage from bug 954740 (bio 1308).
(Assignee)

Updated

4 years ago
Depends on: 954740
(Assignee)

Comment 4

4 years ago
*** Original post on bio 1309 at 2012-05-16 16:01:01 UTC ***

Fixed by bug 954740 (bio 1308).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.2
Assignee: nobody → aleth
You need to log in before you can comment on or make changes to this bug.