If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Failing to join password protected channel using "/join #channel password"

RESOLVED FIXED in 1.2

Status

Chat Core
IRC
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Mic, Assigned: aleth)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
*** Original post on bio 1311 at 2012-03-02 13:09:00 UTC ***

I can't join a password-protected channel with the command "/join #channel password" since JS-IRC landed.

I'm pasting the contents of the error console for the cases "Join from the join-chat-dialog" (working) and using the textual command (not working).

Channel was "#mictest" on the Mozilla IRC network; password was "mypwd", set using "/mode #mictest +k mypwd" (using Mibbit, since /mode doesn't work properly atm).

> From Join Chat dialog:

Sending:
JOIN #mictest :mypwd
onTransportStatus(STATUS_SENDING_TO)
onTransportStatus(STATUS_RECEIVING_FROM)
:Mic|test!Instantbir@< blabla...blub > JOIN :#mictest
:concrete.mozilla.org 353 Mic|test = #mictest :Mic|test clokep_work @Mic|web 
:concrete.mozilla.org 366 Mic|test #mictest :End of /NAMES list.


> Using textual command:

Sending:
JOIN :#mictest mypwd
onTransportStatus(STATUS_SENDING_TO)
onTransportStatus(STATUS_RECEIVING_FROM)
:concrete.mozilla.org 475 Mic|test #mictest :Cannot join channel (+k)
Warning: Unhandled IRC message: :concrete.mozilla.org 475 Mic|test #mictest :Cannot join channel (+k)
Source File: jar:file:///C:/Dokumente%20und%20Einstellungen/internet-user/Desktop/instantbird-1.2a1pre.en-US.win32/instantbird/omni.jar!/components/irc.js
Line: 331
Source Code:
irc
*** Original post on bio 1311 at 2012-03-02 13:17:42 UTC ***

http://lxr.instantbird.org/instantbird/source/chat/protocols/irc/ircCommands.jsm#168 and http://lxr.instantbird.org/instantbird/source/chat/protocols/irc/ircCommands.jsm#173 need to be aMsg.split(" ") (or should probably be made into a simple helper function).

I'm confused at how this worked for me the other day though.
(Assignee)

Comment 2

4 years ago
*** Original post on bio 1311 at 2012-03-30 14:41:42 UTC ***

A dupe of bug 954738 (bio 1306)?
*** Original post on bio 1311 at 2012-03-30 14:42:50 UTC ***

(In reply to comment #2)
> A dupe of bug 954738 (bio 1306)?

Not necessarily. It depends on how the fix is implemented.
*** Original post on bio 1311 at 2012-06-05 01:47:22 UTC ***

I think this is fixed now [1], although it isn't for the alias of /j. (Which I think Florian wants to get rid of, and I'm in favor of that too.)

Mic, can you check that this works as you expect it to? :)

[1] http://lxr.instantbird.org/instantbird/source/chat/protocols/irc/ircCommands.jsm#162
*** Original post on bio 1311 at 2012-06-23 13:41:20 UTC ***

This was fixed as part of bug 953828 (bio 385) (which was committed as http://hg.instantbird.org/instantbird/rev/d267540b8f52)
Assignee: nobody → aleth
Status: NEW → RESOLVED
Last Resolved: 4 years ago
OS: Windows XP → All
Resolution: --- → FIXED
Target Milestone: --- → 1.2
You need to log in before you can comment on or make changes to this bug.