Closed Bug 954893 Opened 8 years ago Closed 8 years ago

Do not send blank lines / empty messages

Categories

(Chat Core :: IRC, defect)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aleth, Assigned: aleth)

References

Details

Attachments

(1 file)

*** Original post on bio 1460 at 2012-05-22 23:26:00 UTC ***

Ending a message with Ctrl-Return Return produces a ERR_NOTEXTTOSEND message. We should not be sending those blank lines.
*** Original post on bio 1460 at 2012-05-22 23:32:33 UTC ***

So I think all you have to do is check in the send message whether the message has any length [1]. The same method will not be changed for both ircChannel and ircConversation.

[1] http://lxr.instantbird.org/instantbird/source/chat/protocols/irc/irc.js#119
Duplicate of this bug: 954916
Summary: Check whether messages to be sent end with blank lines → Do not send blank lines / empty messages
Attached patch PatchSplinter Review
*** Original post on bio 1460 as attmnt 1607 at 2012-06-14 21:35:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8353364 - Flags: review?(clokep)
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Comment on attachment 8353364 [details] [diff] [review]
Patch

*** Original change on bio 1460 attmnt 1607 at 2012-06-15 01:12:39 UTC ***

Couldn't have done it better myself. ;)
Attachment #8353364 - Flags: review?(clokep) → review+
Whiteboard: [checkin-needed]
*** Original post on bio 1460 at 2012-06-21 00:28:17 UTC ***

Checked in as http://hg.instantbird.org/instantbird/rev/9baa0795be9a

Thanks for fixing this annoyance.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [checkin-needed]
Target Milestone: --- → 1.2
You need to log in before you can comment on or make changes to this bug.