Closed Bug 954898 Opened 7 years ago Closed 7 years ago

The first connection attempt of new accounts with non-default settings shouldn't be aborted immediately

Categories

(Chat Core :: General, defect)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: florian, Assigned: florian)

References

Details

Attachments

(1 file)

*** Original post on bio 1465 at 2012-05-24 16:50:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
Blocks: 954888
Attached patch PatchSplinter Review
*** Original post on bio 1465 as attmnt 1524 at 2012-05-24 16:50:00 UTC ***

As discussed in bug 954888 (bio 1455), a disconnect() call on newly created accounts with non-default settings is caused by a bug in the implementation of
_connectionInfoChanged in imAccounts.js
Attachment #8353277 - Flags: review?(clokep)
Comment on attachment 8353277 [details] [diff] [review]
Patch

*** Original change on bio 1465 attmnt 1524 at 2012-05-24 17:03:02 UTC ***

Thanks for the good comments in here!
Attachment #8353277 - Flags: review?(clokep) → review+
*** Original post on bio 1465 at 2012-05-24 17:44:32 UTC ***

Checked in as http://hg.instantbird.org/instantbird/rev/53db88041a77
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.2
You need to log in before you can comment on or make changes to this bug.