Removing an IRC buddy does not remove the ircAccountBuddy

RESOLVED DUPLICATE of bug 957557

Status

Chat Core
IRC
RESOLVED DUPLICATE of bug 957557
5 years ago
5 years ago

People

(Reporter: aleth, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
*** Original post on bio 1570 at 2012-07-04 00:27:00 UTC ***

STR: Removing a buddy, then sending a /msg to the same nick, produces
Warning: reference to undefined property this._buddy, Source File: resource:///modules/jsProtoHelper.jsm Line: 219

09:46:26 PM - clokep_wp7: Aleth: that's a known bug yes. I dobt think anything is on file for it though. We alao need to remove them from ISON queries, etc 
09:47:03 PM - clokep_wp7: Last time i looked, it wasn't clear to me how we're notified of this i think?

remove() on the GenericAccountBuddyPrototype is called, which calls Services.contacts.accountBuddyRemoved and nothing else. This sends out the notification "account-buddy-removed", which gets caught by the corresponding buddy. I can't see at first glance where an account buddy actually gets deleted - maybe it's assumed to be automatic when nothing refers to it any more?
(Reporter)

Comment 1

5 years ago
*** Original post on bio 1570 at 2012-07-04 00:40:03 UTC ***

So, probably the account should listen for "account-buddy-removed".
Things to consider: What happens to open conversation tabs with that account buddy.
Duping this to where work is happening.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 957557
You need to log in before you can comment on or make changes to this bug.