Update the glib version requirements on the website

RESOLVED FIXED

Status

Instantbird Servers
www.instantbird.com
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Instantbot, Assigned: clokep)

Tracking

Details

(Whiteboard: [1.3-wanted])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
*** Original post on bio 1592 by filimonov.mikhail AT gmail.com at 2012-07-13 11:53:00 UTC ***

I have CentOS 5.6 with glib 2.12.3-4.el5_3.1

Application succesfully starting. But when I'm trying to connect to the server it craches, with messages in console:

➜ ./instantbird

(Gecko:30796): GLib-GObject-WARNING **: gsignal.c:1667: signal `button-press-event' is invalid for instance `0xb2c5d140'

(Gecko:30796): GLib-GObject-WARNING **: gsignal.c:1667: signal `button-release-event' is invalid for instance `0xb2c5d140'
./instantbird-bin: symbol lookup error: /home/mf5137/bin/instantbird/libpurple.so: undefined symbol: g_checksum_new

here 
http://developer.gnome.org/glib/2.31/glib-Data-Checksums.html
you can read that 
"Support for checksums has been added in GLib 2.16"

and here 
http://instantbird.com/system-requirements.html
you can read that Intantbird requires GLib 2.12.

So please fix the code to make it compatible with GLib 2.12 (2.16 is now compatible with my CentOS 5.6) - as all other software works good. Or at least fix requirements.
(Reporter)

Comment 1

5 years ago
*** Original post on bio 1592 by filimonov.mikhail AT gmail.com at 2012-07-13 11:54:51 UTC ***

typo: 2.16 is NOT compatible with my CentOS 5.6
(Assignee)

Comment 2

5 years ago
*** Original post on bio 1592 at 2012-07-13 12:06:51 UTC ***

For what it's worth, the version distributed with Instantbird source (and used on Windows) is 2.16.1 (according to my notes).

This is using the downloaded package from instantbird.com, I assume?
*** Original post on bio 1592 at 2012-07-13 13:29:51 UTC ***

Is this a recent regression?

If you are on a nightly, I wonder if the glib version installed on our linux buildslave could have been accidentally updated when we installed libavahi to build the Bonjour plugin.
(Reporter)

Comment 4

5 years ago
*** Original post on bio 1592 by filimonov.mikhail AT gmail.com at 2012-07-13 13:38:09 UTC ***

I've used Instantbird build (not from sources). That was downloaded from 
http://www.instantbird.com/downloads/1.1/instantbird-1.1.en-US.linux-i686.tar.bz2 today.

Comment 5

5 years ago
*** Original post on bio 1592 at 2012-10-17 15:43:21 UTC ***

Pidgin and the Debian libpurple package also require glib>=2.16 as per http://packages.debian.org/en/sid/libpurple0 (I couldn't find any information specific to to libpurple). We should update this, along with the changes from https://bugzilla.mozilla.org/show_bug.cgi?id=793634 if 1.3 is released on >=moz17, which seems likely.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [1.3-wanted]
*** Original post on bio 1592 at 2012-11-05 23:18:28 UTC ***

(In reply to comment #5)
> along with the changes from
> https://bugzilla.mozilla.org/show_bug.cgi?id=793634 if 1.3 is released on
> >=moz17, which seems likely.

At this point it seems Instantbird 1.3 will be on Mozilla 16.0.2.
Component: General → www.instantbird.com
Product: Chat Core → Instantbird Servers
Summary: glib version requirements bad → Update the glib version requirements on the website
Version: 1.1 → unspecified
(Assignee)

Comment 7

5 years ago
Created attachment 8353825 [details] [diff] [review]
Update system requirements

*** Original post on bio 1592 as attmnt 2065 at 2012-11-07 14:45:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8353825 - Flags: review?(florian)
(Assignee)

Updated

5 years ago
Assignee: nobody → clokep
Status: NEW → ASSIGNED
Comment on attachment 8353825 [details] [diff] [review]
Update system requirements

*** Original change on bio 1592 attmnt 2065 at 2012-11-14 00:50:50 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8353825 - Flags: review?(florian) → review+
*** Original post on bio 1592 at 2012-11-14 00:51:15 UTC ***

https://hg.instantbird.org/websites/www.instantbird.com/rev/3d8c3e2b08cb
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.