instantbird can't use proxy to connect gtalk service

RESOLVED DUPLICATE of bug 955075

Status

Chat Core
XMPP
RESOLVED DUPLICATE of bug 955075
4 years ago
4 years ago

People

(Reporter: Instantbot, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
*** Original post on bio 1644 by marble.mabh AT gmail.com at 2012-08-13 07:39:00 UTC ***

I was using instantbird v1.1 for a long time, and really loved this program. And I'm happy to see instantbird updated to v1.2, but when I tried out this new version. I can't get gtalk connected behind a proxy, and there's no proxy available to gtalk service but I can see it on v1.1 or other messenger services even I specify it on options to use global proxy settings.
I also checked the account property, there's proxy settings showing on v1.1, but not on v1.2
Now I have to roll back to v1.1, and hoping you guys can get it fix ASAP, thanks!

--Marble
*** Original post on bio 1644 at 2012-08-13 10:25:02 UTC ***

GTalk, Facebook Chat and IRC now use the general application proxy settings: Tools > Options > "Advanced" tab > "Network" sub-tab > "For everything else (updates, addons, ...)"

Comment 2

4 years ago
*** Original post on bio 1644 at 2012-08-13 16:49:08 UTC ***

The confusion is due to bug 953602 (bio 155) (and gtalk no longer being a libpurple protocol) I think.

> GTalk, Facebook Chat and IRC now use the general application proxy settings:
> Tools > Options > "Advanced" tab > "Network" sub-tab > "For everything else
> (updates, addons, ...)"

If this does not fix the problem for you, please let us know!
OS: Windows 7 → All
Hardware: x86 → All

Updated

4 years ago
Severity: blocker → normal
(Reporter)

Comment 3

4 years ago
*** Original post on bio 1644 by marble.mabh AT gmail.com at 2012-08-14 03:42:59 UTC ***

no, it doesn't work, I already set both proxy settings to same, but it always can not connect to server. I tried to set proxy to "auto detect/manual/system setting", none of them can work with gtalk sevice.
Anything else I can check?

Comment 4

4 years ago
*** Original post on bio 1644 at 2012-08-14 09:09:35 UTC ***

Are you using a HTTP proxy?
(Reporter)

Comment 5

4 years ago
*** Original post on bio 1644 by marble.mabh AT gmail.com at 2012-08-14 14:48:52 UTC ***

Yes, a http proxy @port 80, did you guys test a http proxy?
*** Original post on bio 1644 at 2012-08-14 14:57:08 UTC ***

(In reply to comment #5)
> Yes, a http proxy @port 80
OK, so this is a dup of bug 955075 (bio 1646).

> did you guys test a http proxy?
I don't think any of the developers have a proxy to test with. We explicitly know it doesn't work with HTTP proxies, they were disabled as bug 954781 (bio 1347).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 955075

Comment 7

4 years ago
*** Original post on bio 1644 at 2012-08-14 14:58:54 UTC ***

(In reply to comment #5)
> Yes, a http proxy @port 80, did you guys test a http proxy?

If you have a proxy one can test with, let us know...
(Reporter)

Comment 8

4 years ago
*** Original post on bio 1644 by marble.mabh AT gmail.com at 2012-08-17 06:47:05 UTC ***

Sorry, I use a company proxy that can't be accessed outside.
Maybe you can try a local proxy software like Squid if you're not using one?
http://wiki.squid-cache.org/SquidFaq/BinaryPackages
You need to log in before you can comment on or make changes to this bug.