Closed Bug 955082 Opened 10 years ago Closed 10 years ago

Gtalk login failure: Unexpected data received (XML Parsing Error)

Categories

(Chat Core :: XMPP, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 775977

People

(Reporter: bugzilla, Unassigned)

Details

Attachments

(1 file)

*** Original post on bio 1653 by Secretss <secretss.x AT gmail.com> at 2012-08-17 13:22:00 UTC ***

I connected my Gtalk account and it connects for a second and promptly disconnects and tries to reconnect. This goes on in a cycle until I eventually cancel the reconnection. This problem started ever since I updated to 1.2 and Gtalk login has never worked on 1.2. It was working on 1.1.

I tried another Gtalk account and that second one has no problems connecting.

I do not have 2-step verification on.
*** Original post on bio 1653 as attmnt 1812 by secretss.x AT gmail.com at 2012-08-17 13:24:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
*** Original post on bio 1653 at 2012-08-17 20:04:59 UTC ***

The relevant error in the log is:

Error: parse-fatal-error: XML Parsing Error: prefix must not be bound to one of the reserved namespace names
Location: about:blank
Line Number 1, Column 9418:
Source File: resource:///modules/xmpp-session.jsm
Line: 189

It appears just after sending the user's vCard. The login is already successful and the roster has already been received.
Unfortunately the stanza we failed to parse isn't in the log, as we pretty print stanzas to the error console (ie they are printed after parsing).
Severity: major → normal
OS: Windows 7 → All
Hardware: x86 → All
*** Original post on bio 1653 at 2012-08-29 20:03:00 UTC ***

Also reported here https://bugzilla.mozilla.org/show_bug.cgi?id=775977, so confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Gtalk login failure: Unexpected data received → Gtalk login failure: Unexpected data received (XML Parsing Error)
*** Original post on bio 1653 by Secretss <secretss.x AT gmail.com> at 2013-01-03 07:36:33 UTC ***

Is there any way I can help more with this error? It's still present in v1.3 :(
*** Original post on bio 1653 at 2013-01-03 11:00:17 UTC ***

(In reply to comment #4)
> Is there any way I can help more with this error? It's still present in v1.3 :(

We know what the problem is (see https://bugzilla.mozilla.org/show_bug.cgi?id=775977). Unfortunately, it's a bug on Google's side that causes the gtalk server to send us invalid XML, and there's not much we can do about it :-(.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: