Unhandled IRC message 442: You're not on that channel

RESOLVED FIXED in 1.3

Status

Chat Core
IRC
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aleth, Assigned: clokep)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
*** Original post on bio 1659 at 2012-08-21 23:52:00 UTC ***

STR Attempt to join a key-protected channel with the wrong password when the chat tab for the channel already exists. We try to fetch the TOPIC anyway, get this in response.
(Assignee)

Comment 1

4 years ago
Created attachment 8353636 [details] [diff] [review]
Patch

*** Original post on bio 1659 as attmnt 1878 at 2012-09-01 01:40:00 UTC ***

I can't reproduce with these steps.

I tested this with:
/quote TOPIC #testib Test

While not in #testib.
Attachment #8353636 - Flags: review?(bugzilla)
(Assignee)

Updated

4 years ago
Assignee: nobody → clokep
Status: NEW → ASSIGNED
(Reporter)

Comment 2

4 years ago
Comment on attachment 8353636 [details] [diff] [review]
Patch

*** Original change on bio 1659 attmnt 1878 at 2012-09-01 11:04:33 UTC ***

(In reply to comment #1)
> I can't reproduce with these steps.
I suppose we fixed whatever was causing this with the changes to /join? From the current code, I can't see how we would request the topic. If it happens again, we can file another bug.
Attachment #8353636 - Flags: review?(bugzilla) → review+
(Reporter)

Updated

4 years ago
Whiteboard: [checkin-needed]
(Assignee)

Comment 3

4 years ago
*** Original post on bio 1659 at 2012-09-02 12:51:49 UTC ***

(In reply to comment #2)
> (In reply to comment #1)
> > I can't reproduce with these steps.
> I suppose we fixed whatever was causing this with the changes to /join? From
> the current code, I can't see how we would request the topic.
I can't either, although I don't see any check-ins that fixed this. Maybe we saw this with a broken patch?

> If it happens again, we can file another bug.
We should obviously still handle the error though. :) Thanks for the review.
(Reporter)

Comment 4

4 years ago
*** Original post on bio 1659 at 2012-09-04 18:48:18 UTC ***

http://hg.instantbird.org/instantbird/rev/61a75f432337
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
Whiteboard: [checkin-needed]
(Reporter)

Updated

4 years ago
Target Milestone: --- → 1.3
You need to log in before you can comment on or make changes to this bug.