Closed Bug 955204 Opened 8 years ago Closed 8 years ago

IRC account disconnects on receiving action messages containing line breaks

Categories

(Chat Core :: IRC, defect)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aleth, Assigned: clokep)

References

Details

(Whiteboard: [1.3-blocking])

Attachments

(2 files)

*** Original post on bio 1772 at 2012-11-06 20:08:00 UTC ***

STR
Send "/me one\ntwo" (i.e. with a line break after the "one") to IB from IB.
*** Original post on bio 1772 at 2012-11-06 20:12:57 UTC ***

On the receiving end, we see
Timestamp: 11/06/2012 09:07:37 PM
Error: Couldn't parse message: ":adev!adev@moz-711349EF.ictp.it PRIVMSG #tckk :ACTION one
two"
*** Original post on bio 1772 at 2012-11-06 20:25:10 UTC ***

Being able to disconnect someone from an IRC network from remote is a serious problem, we definitely need to fix this.
Severity: normal → critical
Whiteboard: [1.3-blocking]
Duplicate of this bug: 955188
Attached patch Fix v1Splinter Review
*** Original post on bio 1772 as attmnt 2063 at 2012-11-06 21:15:00 UTC ***

This just makes the regex a little bit greedier to match any character (\s\S) instead of "any character except newlines" (.).

Oh, and I added tests.
Attachment #8353823 - Flags: review?(bugzilla)
Assignee: nobody → clokep
Status: NEW → ASSIGNED
Comment on attachment 8353823 [details] [diff] [review]
Fix v1

*** Original change on bio 1772 attmnt 2063 at 2012-11-06 21:26:58 UTC ***

For the record, the message on the send side was escaped correctly. We parse the message after unescaping, so \n etc can be present.

Thanks for fixing this & the tests :)
Attachment #8353823 - Flags: review?(bugzilla) → review+
Whiteboard: [1.3-blocking] → [1.3-blocking][checkin-needed]
*** Original post on bio 1772 as attmnt 2064 at 2012-11-06 21:52:00 UTC ***

Pushing the r+ forward as this just removes two print statements.
Attachment #8353824 - Flags: review+
*** Original post on bio 1772 at 2012-11-06 22:55:09 UTC ***

Fixed in http://hg.instantbird.org/instantbird/rev/78d0ac8bcc44
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [1.3-blocking][checkin-needed] → [1.3-blocking]
Target Milestone: --- → 1.3
See Also: → 810330
You need to log in before you can comment on or make changes to this bug.